Modify

Opened 9 years ago

Closed 8 years ago

#11124 closed defect (duplicate)

Duplicated via-nodes of restriction-relation when detaching lines using key G

Reported by: imagic Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: restriction relation via unglue Cc:

Description

See the attached .osm file:

  • a restriction-relation is used on the two ways leading north (from-way and to-way)
  • a third way connects at the middle node; this way is not part of the relation, but the node is the via-node of it

Now do the following:

  • Select the way, which is not part of the relation
  • Press and hold Shift and additionally select the node in the middle
  • Press "G"

Now the relation contains two via-nodes. This should be avoided.

Intended behaviour: If the via-node of a restriction-relation is duplicated, remove that node from the relation, that is not part of either the from-way or the to-way.

Attachments (1)

Duplicated via-node.osm (1.3 KB ) - added by imagic 9 years ago.
Example file

Download all attachments as: .zip

Change History (4)

by imagic, 9 years ago

Attachment: Duplicated via-node.osm added

Example file

comment:1 by Don-vip, 9 years ago

Keywords: restriction relation via unglue added

comment:2 by simon04, 9 years ago

#8838 is related. Currently, all node's relation memberships are duplicated to the new node. In most cases this is undesired.

comment:3 by simon04, 8 years ago

Resolution: duplicate
Status: newclosed

Closed as duplicate of #8838.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.