Modify

Opened 9 years ago

Closed 7 years ago

#8721 closed enhancement (duplicate)

Sort autocompletion for tags by frequentness

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: taginfo autocompletion Cc:

Description

I would like to have a change of the behaivor of the autocompletion. The tags are completed by alphabet for now. There are several issues which are for example addr:ho goes to addr:housename which is not that often used as addr:housenumber. Like ticket #8275 shows.

Attachments (0)

Change History (14)

comment:1 Changed 9 years ago by Don-vip

Keywords: taginfo added

Well, maybe we could request periodically and cache a small extract of taginfo database to implement this.

comment:2 Changed 9 years ago by Zverikk

Maybe just use usage statistics from already loaded map extract?

Though autocompletion and sorting by taginfo stats would be a great feature.

comment:3 Changed 9 years ago by stoecker

Problem with the sorting is, that finding an entry is much more complicated if you don't know the sort order.

comment:4 Changed 9 years ago by Zverikk

But does anyone really use the list to choose values? If you don't know which value to set, sorting by popularity is more useful. Alphabetical sorting for me does more bad than good, and the housename/housenumber example is the most annoying one (building:cladding/building:levels coming second, and shelter/shop — third).

comment:5 Changed 9 years ago by Don-vip

Could we use alphabetical sorting when displaying the list, and frequentness when using autocompletion ?

comment:6 Changed 9 years ago by Zverikk

Actually I think frequentness sorting is more important when displaying the list. And it could be used with empty input fields, and even for keys.

comment:7 in reply to:  5 ; Changed 9 years ago by skyper

Replying to Zverikk:

But does anyone really use the list to choose values?

Yes, I do, but this might change if autocompletion works better.

Replying to Don-vip:

Could we use alphabetical sorting when displaying the list, and frequentness when using autocompletion ?

+1

at least for keys this is needed, otherwise the list will be more or less useless cause you will not easily find the key you are looking for.

comment:8 in reply to:  7 ; Changed 9 years ago by Zverikk

Replying to skyper:

Replying to Don-vip:

Could we use alphabetical sorting when displaying the list, and frequentness when using autocompletion ?

+1
at least for keys this is needed, otherwise the list will be more or less useless cause you will not easily find the key you are looking for.

Experienced mappers know what are they looking for, and can easily type first letters into the field. Novice mappers, who will open the list, often without typing anything, will be looking for a most relevant key or value, and alphabetical sorting doesn't give them that.

comment:9 in reply to:  8 ; Changed 9 years ago by skyper

Replying to Zverikk:

Replying to skyper:

Replying to Don-vip:

Could we use alphabetical sorting when displaying the list, and frequentness when using autocompletion ?

+1
at least for keys this is needed, otherwise the list will be more or less useless cause you will not easily find the key you are looking for.

Experienced mappers know what are they looking for, and can easily type first letters into the field. Novice mappers, who will open the list, often without typing anything, will be looking for a most relevant key or value, and alphabetical sorting doesn't give them that.

Sorry, but if you do not know what you are looking for, you should always use presets and the preset search function (localized !). With a totally mixed list some might find the major used values first but a lot will not find other tags easily.

I often use the up and down arrows which does only work if you know the order of the list. Just try add right now and please tell me the order of the addr:* keys sorted after usage.

comment:10 in reply to:  9 ; Changed 9 years ago by Zverikk

Replying to skyper:

I often use the up and down arrows which does only work if you know the order of the list. Just try add right now and please tell me the order of the addr:* keys sorted after usage.

I am pretty sure addr:housenumber and addr:street will be in first two lines, instead of fairly useless (in our country) addr:country and addr:housename as it is now.

comment:11 in reply to:  10 Changed 9 years ago by skyper

Replying to Zverikk:

Replying to skyper:

I often use the up and down arrows which does only work if you know the order of the list. Just try add right now and please tell me the order of the addr:* keys sorted after usage.

I am pretty sure addr:housenumber and addr:street will be in first two lines, instead of fairly useless (in our country) addr:country and addr:housename as it is now.

This would mean that we have to filter the list.

comment:12 Changed 8 years ago by mdk

I think every mapper has his own set of tags he is using normally. So JOSM should learn these tags just by counting the users input instead of counting the tag usage in the currently downloaded data. I never know which tags are suggested by JOSM, when I start mapping in a new area.

Here is an example:

Normally I add barriers like fence, hedge, wall, gate, etc. by tying in be<ENTER>fe<Enter>. But somewhere in my area there is a barometer=*. In this case I create a "barometer=fe" instead of "barrier=fence".

The barometer tag is only used 159 times on the whole world. But because it is alphabetically before barrier (which is used 3417789 times), I do this mistake. I normally found it, when I check the Validator "info" messages about unknown values. The interesting thing is, that more than 10% of the barometer=* tags which are in our data are failures created by the actual suggestion mechanism:

  • 4 times (2.52%) "g" which should be barrier=gate
  • 3 times (1.89%) "fe" which should be barrier=fence
  • 3 times (1.89%) "ditch" which should be barrier=ditch
  • 2 times (1.26%) "gate" which should be barrier=gate
  • 2 times (1.26%) "f" which should be barrier=fence
  • 2 times (1.26%) "wall" which should be barrier=wall
  • 2 times (1.26%) "retaining_wall" which should be barrier=retaining_wall
  • 2 times (1.26%) "w" which should be barrier=wall
  • 1 times (0.63%) "hed" which should be barrier=hedge
  • 1 times (0.63%) "wa" which should be barrier=wall

So ALL values except of "yes" and "no" are wrong because of unexpected suggestions of the key!

And what hurts me most is, that somebody adds "tracks=*" to the railways in my area, so if I add a highway=track & tracktype=grade<n> I always have to type trackt<ENTER> to get the right key.


comment:13 Changed 7 years ago by Don-vip

Keywords: autocompletion added

comment:14 Changed 7 years ago by bastiK

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11048.
This is sort of fixed in r7725. Discussion of the shortcomings of that change in #11048.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.