Modify

Opened 8 years ago

Closed 2 years ago

#8663 closed enhancement (fixed)

preset: object type "closedway" should not be included in type "way"

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: preset Cc:

Description

The object type closedway is include in type way but it makes more sense to use them as two different objects in order to distinguish between areas and linear objects.

Attachments (0)

Change History (10)

comment:1 Changed 8 years ago by skyper

Version: latest

comment:2 Changed 8 years ago by stoecker

No. There always will be cases where closed ways aren't areas. Excluding closed ways from ways would result in very strange behaviour, which users will hardly understand.

comment:3 Changed 8 years ago by Don-vip

Resolution: wontfix
Status: newclosed

comment:4 Changed 8 years ago by skyper

Does way,!closedway work ?

comment:5 Changed 8 years ago by stoecker

Resolution: wontfix
Status: closedreopened

comment:6 Changed 8 years ago by Don-vip

Type: defectenhancement

comment:7 Changed 7 years ago by skyper

The behaviour did change and closed ways are no longer part of way. Not sure if it was intended though. Personally I do not have one favourite solution but I understand that excluding closed ways explicitly might have some advantages.

comment:8 in reply to:  7 Changed 7 years ago by skyper

Replying to skyper:

The behaviour did change and closed ways are no longer part of way. Not sure if it was intended though. Personally I do not have one favourite solution but I understand that excluding closed ways explicitly might have some advantages.

Is the solution now accepted and we can close this ticket ?

See also #8724 and #8879 which are related.

comment:9 Changed 6 years ago by skyper

Think the solution is now accepted and we can close this ticket.

My comment on #8724 still needs a decision though.

comment:10 Changed 2 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.