Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8638 closed defect (fixed)

GUI - tag vending for vending_machine with ";"

Reported by: Manu1400 Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: GUI; vending_machine; multiselect Cc:

Description

The <multiselect> part of presets have problems with semi-colon value separator :

Example :
I want to add a other value of vending for a vending_machine which use semi-colon value separator.
amenity=vending_machine
vending=drinks;cigarettes
If i use the GUI for modified the tag 'vending' it's not possible (because values aren't in the order of JOSM preset).
But i "valid" that, the tag 'vending' is "modified" to the value "cigarettes;drinks".

Solutions :

  • Don't change the order of values
  • Patch the Core (see #8605) to accept values without order.

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by Manu1400

And with the version lasted it's different (see http://josm.openstreetmap.de/changeset/5866/josm) :

http://josm.openstreetmap.de/changeset/5866/josm contain a "regression" for users :
The order is NOT "modified" and "block" the GUI.

comment:2 Changed 7 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 5912/josm:

fix #8638 - Presets: Allow editing of multiselect values in wrong order

comment:3 Changed 7 years ago by Don-vip

The order modification is not a problem: the values are semantically equal. It is even better to have consistent values in alphabetical order. Regression fixed.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.