Modify

Opened 6 years ago

Closed 6 years ago

#8637 closed defect (duplicate)

undelete plugin doesn't recover history properly, thus preventing re-uploading of deleted items

Reported by: rickmastfan67 Owned by: team
Priority: blocker Milestone:
Component: Plugin undelete Version: latest
Keywords: Cc:

Description

For instance, if you download a node for example, the line for it in your OSM file would be as follows:
<node id='256468302' timestamp='2008-04-08T19:19:18Z' uid='24807' user='mikecanann' visible='true' version='1' changeset='88722' lat='39.0441681' lon='-84.3740155' />

But, when a node or way is undeleted, the undelete plugin doesn't get the "changeset='88722'" or the "timestamp='*'" info producing a line like this in your OSM file:
<node id='333782503' action='modify' uid='33757' user='Minh Nguyen' visible='true' version='9' lat='39.0508914' lon='-84.3899269'>

Because of this, when you try to re-upload the way/node to the database, it fails. Until this can be fixed, the only reliable way to undelete single ways/nodes is to use potlatch1 (unless you're reverting an entire changeset).

Here's a way that you can use to test this with: http://www.openstreetmap.org/browse/way/19528232

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-04-26 01:34:33
Last Changed Author: Don-vip
Revision: 5904
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-04-26 00:35:45 +0200 (Fri, 26 Apr 2013)
Last Changed Rev: 5904

Identification: JOSM/1.5 (5904 en) Windows 7 64-Bit
Memory Usage: 255 MB / 2730 MB (139 MB allocated, but free)
Java version: 1.7.0_21, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Xmx3072M]
Dataset consistency test: No problems found

Plugin: ImageryCache (29484)
Plugin: OpeningHoursEditor (29435)
Plugin: buildings_tools (29435)
Plugin: mapdust (29525)
Plugin: measurement (29534)
Plugin: mirrored_download (29505)
Plugin: openstreetbugs (29435)
Plugin: osmarender (29435)
Plugin: reverter (29503)
Plugin: turnrestrictions (29435)
Plugin: undelete (29538)
Plugin: utilsplugin2 (29435)

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by Don-vip

It's because the way is uploaded before its two restored nodes:

PUT http://api.openstreetmap.org/api/0.6/changeset/create... OK
PUT http://api.openstreetmap.org/api/0.6/way/19528232... Precondition Failed
Error header: Precondition failed: Way 19528232 requires the nodes with id in (202882730), which either do not exist, or are not visible.

comment:2 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7116.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.