Modify

Opened 7 years ago

Closed 4 years ago

#8458 closed enhancement (duplicate)

put validation layer behind data layer

Reported by: BFX Owned by: team
Priority: normal Milestone:
Component: Core validator Version: latest
Keywords: Cc: mkoniecz

Description

Every time I have to move the validation layer behind the data layer.
If the validation layer is in the foreground, I can not click on nodes and ways which are behind the layer.

Can you put the validation layer behind the active data layer by default?

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by skyper

Ticket #9320 has been marked as a duplicate of this ticket.

comment:2 Changed 6 years ago by skyper

Cc: mkoniecz added

From #9320:

Replying to Bulwersator:

When I create "Validation errors" layer by validating some OSM data, it is put at the top of the stack.

Once I use "Zoom to problem" the line is obscured by marking line with very wide line - see default.png

Switching layers makes possible to again see marked way - see better.png

related to #3529

Maybe it would be better fixing by changing complete fill into something more discreet (half transparent fill)?

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-11-15 02:34:58
Last Changed Author: Don-vip
Revision: 6386
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-11-15 02:00:02 +0100 (Fri, 15 Nov 2013)
Last Changed Rev: 6386

Identification: JOSM/1.5 (6386 en_GB) Windows 7 32-Bit
Memory Usage: 247 MB / 247 MB (81 MB allocated, but free)
Java version: 1.7.0_45, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugin: OpeningHoursEditor (29854)
Plugin: notes (v0.6)
Last edited 6 years ago by skyper (previous) (diff)

comment:3 Changed 4 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #12634.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.