Modify

Opened 7 years ago

Closed 6 years ago

Last modified 2 years ago

#8434 closed defect (fixed)

[patch] Falsches Preset: man_made=measurement_station - sollte sein: monitoring_station

Reported by: cmuelle8 Owned by: team
Priority: normal Milestone: 13.12
Component: Internal preset Version: latest
Keywords: Cc:

Attachments (5)

patch_monitoring_station.diff (1.3 KB) - added by malenki 6 years ago.
patch_monitoring_station.patch (1.3 KB) - added by malenki 6 years ago.
monitoring_station.patch (1.3 KB) - added by malenki 6 years ago.
monitoring_station.2.patch (1.3 KB) - added by malenki 6 years ago.
josm_8434_update.diff (3.1 KB) - added by skyper 6 years ago.
update

Download all attachments as: .zip

Change History (42)

comment:1 Changed 7 years ago by cmuelle8

Bitte auch den subkey anpassen..

monitoring= statt measurement=
river_level statt water_level
etc.

comment:3 Changed 7 years ago by Don-vip

Priority: majornormal

comment:4 Changed 6 years ago by skyper

There is a nice part about the truth of numbers on the talk page of measurement_station.

comment:5 in reply to:  4 ; Changed 6 years ago by cmuelle8

Replying to skyper:

There is a nice part about the truth of numbers on the talk page of measurement_station.

I don't get your point. You want to use this argument to underline .. what? If you read the talk page to the bottom, it clearly tends to prefer monitoring_station and further suspects: "One of several reasons could be that JOSM has a template for measurement_station." This is why I've opened this bug, josm is at fault here .. since long.

Arguably, osm wiki authors view is subjective and it's not always easy to find a consent in wiki pages, esp. when it comes to talk:-prefixed ones. In this case however, the opinions in the wiki cohere to the (live and wiki-snapshotted) numbers delivered by taginfo. Considering the suspicion vowed above, we should even apply a negative bias to measurement_station numbers before comparing both.

Question remains - why are we sticking to measurement_station here? Esp. when the sole reason of having a significant occurence of this value at all in OSM seems to be the fact, that josm distributed this poor preset in the first place .. and still does?

Thanks for your time.

comment:6 Changed 6 years ago by cmuelle8

Description: modified (diff)

@Don-vip: Danke für die Link-Hinweise - Änderung in die Beschreibung übernommen..

comment:7 Changed 6 years ago by Don-vip

You're welcome, but I don't speak German :D

comment:8 in reply to:  5 ; Changed 6 years ago by skyper

Replying to cmuelle8:

Replying to skyper:

There is a nice part about the truth of numbers on the talk page of measurement_station.

I don't get your point. You want to use this argument to underline .. what? If you read the talk page to the bottom, it clearly tends to prefer monitoring_station and further suspects: "One of several reasons could be that JOSM has a template for measurement_station." This is why I've opened this bug, josm is at fault here .. since long.

Sorry, I did not want to make any judgement or argument but only remind myself and others that numbers do not always tell the truth.

You are right that JOSM should not prefer one of the two tags and if so we should consider using monitoring. I read both pages + talk pages yesterday and did not get the impression that the issue is settled.

I am already involved in some discussions at talk-de@ and tagging@ that's why I did not start another one yesterday but we should get this settled for sure and clean up !

comment:9 in reply to:  8 Changed 6 years ago by anonymous

Ok, thanks for still watching this.
Truth is man_made, I'm not sure about numbers. ;-)

Greetings

comment:10 in reply to:  8 ; Changed 6 years ago by cmuelle8

What about changing this now - considering that the proposal for measurement_station is three years old and nothing substantially changed? Currently, measurement_station does not even have a tag description, while monitoring_station does.

Just looking at the terms I'd prefer measurement myself, but it's not what people use. Maybe we should add a subkey:

monitoring=remote

to indicate that monitoring is not done at the same place where measurement takes place.

Or someone starts dissecting the terms in the wiki and clearly states sth like:

"Monitoring station is a place where humans actually monitor measured data." and

"Measurement station is a place where data is taken, possibly recorded and either collected manually at a certain interval or transmitted by wifi or wire."

In case measurement and monitoring take place on the same site, then, depending on the size of the site, mappers can either decide to micromap the site and still tag measurement and monitoring separately

OR tag it as one of both and specify that the other is done as well by using a dedicated subkey.

Greetings

comment:11 in reply to:  10 Changed 6 years ago by skyper

Replying to cmuelle8:

What about changing this now - considering that the proposal for measurement_station is three years old and nothing substantially changed? Currently, measurement_station does not even have a tag description, while monitoring_station does.

As already said, I'd like to first have a conclusion and then clean up and changes. Two or three more weeks won't hurt as we need a transition anyway.

Please open a discussion at tagging@ with your arguments:

Just looking at the terms I'd prefer measurement myself, but it's not what people use. Maybe we should add a subkey:

monitoring=remote

to indicate that monitoring is not done at the same place where measurement takes place.

Or someone starts dissecting the terms in the wiki and clearly states sth like:

"Monitoring station is a place where humans actually monitor measured data." and

"Measurement station is a place where data is taken, possibly recorded and either collected manually at a certain interval or transmitted by wifi or wire."

In case measurement and monitoring take place on the same site, then, depending on the size of the site, mappers can either decide to micromap the site and still tag measurement and monitoring separately

OR tag it as one of both and specify that the other is done as well by using a dedicated subkey.

Thanks.

comment:12 Changed 6 years ago by Don-vip

There's a vote in progress:
http://wiki.openstreetmap.org/wiki/Proposed_features/monitoring_station#Voting

To promote monitoring and deprecate measurement. I voted yes.

comment:13 Changed 6 years ago by malenki

Didn't even know about this ticket until it was mentioned in the voting process for the proposal of monitoring_station.
Thanks for pointing here.

comment:14 Changed 6 years ago by Don-vip

Vote is finished and everyone approved the proposal => we should then switch to monitoring station and deprecate measurement station :)

comment:15 in reply to:  14 Changed 6 years ago by malenki

Replying to Don-vip:

Vote is finished and everyone approved the proposal => we should then switch to monitoring station and deprecate measurement station :)

+1
Please don't forget to update the secondary tagging, too.

comment:16 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 6385/josm:

fix #8434 - Full support of man_made=monitoring_station instead of man_made=measurement_station:

  • rename icon
  • update presets
  • update map style
  • deprecate old tags
  • fix a bug in tagchecker where keys defined inside checkgroups were not known from validator

comment:17 Changed 6 years ago by malenki

Resolution: fixed
Status: closedreopened

Thanks fo the quick work, but the secondary tagging in the preset doesn't match the approved tagging, e.g. recording=manually instead of recording:manually=yes.

comment:18 Changed 6 years ago by Don-vip

I didn't notice this part of the proposal :( I thought the only goal was to harmonize measurement and monitoring. What's the point to change display and recording tagging ? They don't look broken to me.

comment:19 Changed 6 years ago by malenki

In short: an example: http://www.openstreetmap.org/browse/way/125685956

More detailed:
The same question was asked and the answer you can find on my blog in the comments (recently added a PS): http://www.openstreetmap.org/user/malenki/diary/20339

comment:20 Changed 6 years ago by Don-vip

Alright :) Thanks for these real examples :)

comment:21 Changed 6 years ago by malenki

Hope this gets pulled: https://github.com/openstreetmap/josm/pull/7
(My first try)

Last edited 6 years ago by malenki (previous) (diff)

comment:22 Changed 6 years ago by simon04

Pull requests won't be merged since JOSM uses SVN, but will be committed to SVN manually. :-)

comment:23 Changed 6 years ago by malenki

The svn at osm.org?

comment:24 Changed 6 years ago by Don-vip

Please provide SVN patches here, we don't use Github this is just an unofficial mirror.
See DevelopersGuide/PatchGuide for details :)

comment:25 Changed 6 years ago by skyper

Please, pay attention to white spaces.
We use four for indent and a single one between arguments. No tabs. - Thanks

Changed 6 years ago by malenki

Changed 6 years ago by malenki

Changed 6 years ago by malenki

Attachment: monitoring_station.patch added

comment:26 Changed 6 years ago by malenki

*grmbl*
The attachment page was loading so slow I cancelled the upload two times to give the patch a better name... *sigh*
Except for the name the attachments are identical. Take what you like best. :S

comment:27 in reply to:  26 ; Changed 6 years ago by skyper

Replying to malenki:

*grmbl*
The attachment page was loading so slow I cancelled the upload two times to give the patch a better name... *sigh*
Except for the name the attachments are identical. Take what you like best. :S

Please, no empty lines.

Why don't we add two checkgroups with three columns, one for recording and one for display ?

Changed 6 years ago by malenki

Attachment: monitoring_station.2.patch added

comment:28 in reply to:  27 ; Changed 6 years ago by malenki

Replying to skyper:

Why don't we add two checkgroups with three columns, one for recording and one for display ?

What would the third column be?

Besides, I enhanced the preset as good as I could since no one seemed to have interest to do so. If you want to enhance it further: please do so.

comment:29 in reply to:  28 Changed 6 years ago by skyper

Replying to malenki:

Replying to skyper:

Why don't we add two checkgroups with three columns, one for recording and one for display ?

What would the third column be?

For display it would be empty but you are right only two for display are better suited.

Besides, I enhanced the preset as good as I could since no one seemed to have interest to do so. If you want to enhance it further: please do so.

Hey, sorry, I was only asking.
That noone is working on some tickets might have a lot of reasons. One of the first is lack of time. One of the latest is probably a lack of interest.

comment:30 Changed 6 years ago by simon04

In 6389/josm:

see #8434 - improve additional information for monitoring_station preset - patch by malenki

Changed 6 years ago by skyper

Attachment: josm_8434_update.diff added

update

comment:31 Changed 6 years ago by skyper

Did add my suggestion as patch

comment:32 in reply to:  31 Changed 6 years ago by skyper

Replying to skyper:

Did add my suggestion as patch

Think, this does look nicer but it changes strings again.

comment:33 Changed 6 years ago by skyper

Summary: Falsches Preset: man_made=measurement_station - sollte sein: monitoring_station[patch] Falsches Preset: man_made=measurement_station - sollte sein: monitoring_station

comment:34 Changed 6 years ago by malenki

To me it doesn't matter which patch gets applied as long as tag/value remain correct.

comment:35 Changed 6 years ago by simon04

Resolution: fixed
Status: reopenedclosed

In 6402/josm:

fix #8434 - improve arrangement of additional information for monitoring_station preset - patch by skyper

comment:36 Changed 6 years ago by Don-vip

Milestone: 13.12 (6502)

comment:37 Changed 2 years ago by stoecker

Milestone: 13.12 (6502)13.12

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.