Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8433 closed defect (fixed)

NPEs when opening relation editor or selecting in list from selection toggle dialog's context menu with active filter of relation list

Reported by: skyper Owned by: Don-vip
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description (last modified by skyper)

What steps will reproduce the problem?

  1. open data with several relation
  2. filter in relation list toggle dialog
  3. select a filtered relation
  4. (A) open relation editor from selection list context menu
    (B) or try to select it in relation list

What is the expected result?

  1. open the relation editor
  2. reset filter and select relation in list

What happens instead?

NPE

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-02-17 02:31:24
Last Changed Author: Don-vip
Revision: 5723
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-02-16 16:58:22 +0100 (Sat, 16 Feb 2013)
Last Changed Rev: 5723

Identification: JOSM/1.5 (5723 de)
Memory Usage: 298 MB / 643 MB (55 MB allocated, but free)
Java version: 1.6.0_24, Sun Microsystems Inc., OpenJDK 64-Bit Server VM
Operating system: Linux
Dataset consistency test: No problems found


java.lang.NullPointerException
	at javax.swing.JComponent.scrollRectToVisible(JComponent.java:3063)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog.selectRelations(RelationListDialog.java:297)
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog.selectRelation(RelationListDialog.java:283)
	at org.openstreetmap.josm.gui.dialogs.SelectionListDialog$EditRelationSelection.actionPerformed(SelectionListDialog.java:407)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2012)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2335)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:404)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:374)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:829)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:873)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6389)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3268)
	at java.awt.Component.processEvent(Component.java:6154)
	at java.awt.Container.processEvent(Container.java:2045)
	at java.awt.Component.dispatchEventImpl(Component.java:4750)
	at java.awt.Container.dispatchEventImpl(Container.java:2103)
	at java.awt.Component.dispatchEvent(Component.java:4576)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4633)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4297)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4227)
	at java.awt.Container.dispatchEventImpl(Container.java:2089)
	at java.awt.Window.dispatchEventImpl(Window.java:2518)
	at java.awt.Component.dispatchEvent(Component.java:4576)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:672)
	at java.awt.EventQueue.access$400(EventQueue.java:96)
	at java.awt.EventQueue$2.run(EventQueue.java:631)
	at java.awt.EventQueue$2.run(EventQueue.java:629)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:116)
	at java.awt.EventQueue$3.run(EventQueue.java:645)
	at java.awt.EventQueue$3.run(EventQueue.java:643)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:642)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by skyper

Description: modified (diff)

comment:2 Changed 7 years ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned

comment:3 Changed 7 years ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 5725/josm:

fix #8433 - NPEs when opening relation editor or selecting in list from selection toggle dialog's context menu with active filter of relation list

comment:4 Changed 7 years ago by anonymous

Ticket #8487 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.