Modify

Opened 6 years ago

Closed 6 years ago

#8295 closed defect (duplicate)

JOSM crash during exit

Reported by: Gilbert54 Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: crash, exit Cc:

Description

What steps will reproduce the problem?

  1. I closed JOSM

What is the expected result?
JOSM exits

What happens instead?
exception occured while closing

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-11-29 02:31:07
Last Changed Author: stoecker
Revision: 5608
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-11-28 23:47:46 +0100 (Wed, 28 Nov 2012)
Last Changed Rev: 5608

Identification: JOSM/1.5 (5608 en_GB)
Memory Usage: 391 MB / 494 MB (104 MB allocated, but free)
Java version: 1.7.0_09, Oracle Corporation, Java HotSpot(TM) Client VM
Operating system: Windows 7


java.awt.IllegalComponentStateException: component must be showing on the screen to determine its location
	at java.awt.Component.getLocationOnScreen_NoTreeLock(Unknown Source)
	at java.awt.Component.getLocationOnScreen(Unknown Source)
	at org.openstreetmap.josm.tools.WindowGeometry.<init>(WindowGeometry.java:127)
	at org.openstreetmap.josm.gui.ExtendedDialog.setVisible(ExtendedDialog.java:464)
	at org.openstreetmap.josm.gui.dialogs.relation.GenericRelationEditor.setVisible(GenericRelationEditor.java:582)
	at org.openstreetmap.josm.gui.dialogs.relation.RelationDialogManager.layerRemoved(RelationDialogManager.java:196)
	at org.openstreetmap.josm.gui.MapView.fireLayerRemoved(MapView.java:176)
	at org.openstreetmap.josm.gui.MapView.removeLayer(MapView.java:407)
	at org.openstreetmap.josm.Main.exitJosm(Main.java:691)
	at org.openstreetmap.josm.gui.MainApplication$1.windowClosing(MainApplication.java:84)
	at java.awt.AWTEventMulticaster.windowClosing(Unknown Source)
	at java.awt.AWTEventMulticaster.windowC

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #6438.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.