Modify

Opened 8 years ago

Closed 6 years ago

#6438 closed defect (fixed)

IllegalComponentStateException when closing JOSM

Reported by: dieterdreist Owned by: dieterdreist
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc: Gilbert54, skyper

Description (last modified by Don-vip)

After editing and uploading I tried to close JOSM (ctrl+q on my system (linux)), and got this exception:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-06-06 01:31:37
Last Changed Author: stoecker
Revision: 4125
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-06-05 14:15:21 +0200 (Sun, 05 Jun 2011)
Last Changed Rev: 4125

Identification: JOSM/1.5 (4125 en)
Memory Usage: 657 MB / 989 MB (265 MB allocated, but free)
Java version: 1.6.0_24, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Linux

Plugin: ImportImagePlugin (25934)
Plugin: PicLayer (25219)
Plugin: alignways (25199)
Plugin: buildings_tools (25905)
Plugin: dataimport (25192)
Plugin: osmarender (25371)
Plugin: pdfimport (25546)
Plugin: photo_geotagging (25199)
Plugin: public_transport (25192)
Plugin: restart (25199)
Plugin: reverter (26047)
Plugin: tagging-preset-tester (25191)
Plugin: undelete (26073)
Plugin: waypoint_search (25191)

java.awt.IllegalComponentStateException: component must be showing on the screen to determine its location
	at java.awt.Component.getLocationOnScreen_NoTreeLock(Component.java:1965)
	at java.awt.Component.getLocationOnScreen(Component.java:1939)
	at org.openstreetmap.josm.tools.WindowGeometry.<init>(WindowGeometry.java:98)
	at org.openstreetmap.josm.gui.ExtendedDialog.setVisible(ExtendedDialog.java:446)
	at org.openstreetmap.josm.gui.dialogs.relation.GenericRelationEditor.setVisible(GenericRelationEditor.java:578)
	at org.openstreetmap.josm.gui.dialogs.relation.RelationDialogManager.layerRemoved(RelationDialogManager.java:196)
	at org.openstreetmap.josm.gui.MapView.fireLayerRemoved(MapView.java:152)
	at org.openstreetmap.josm.gui.MapView.removeLayer(MapView.java:361)
	at org.openstreetmap.josm.Main.exitJosm(Main.java:550)
	at org.openstreetmap.josm.gui.MainApplication$1.windowClosing(MainApplication.java:75)
	at java.awt.AWTEventMulticaster.windowClosing(AWTEventMulticaster.java:332)
	at java.awt.Window.processWindowEvent(Window.java:1865)
	at javax.swing.JFrame.processWindowEvent(JFrame.java:274)
	at java.awt.Window.processEvent(Window.java:1823)
	at java.awt.Component.dispatchEventImpl(Component.java:4652)
	at java.awt.Container.dispatchEventImpl(Container.java:2099)
	at java.awt.Window.dispatchEventImpl(Window.java:2478)
	at java.awt.Component.dispatchEvent(Component.java:4482)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:644)
	at java.awt.EventQueue.access$000(EventQueue.java:85)
	at java.awt.EventQueue$1.run(EventQueue.java:603)
	at java.awt.EventQueue$1.run(EventQueue.java:601)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:98)
	at java.awt.EventQueue$2.run(EventQueue.java:617)
	at java.awt.EventQueue$2.run(EventQueue.java:615)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:614)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (12)

comment:1 Changed 8 years ago by stoecker

Owner: changed from team to dieterdreist
Status: newneedinfo

Can you reproduce this? At least relation editor was somehow involved in it.

comment:2 Changed 8 years ago by dieterdreist

No, sorry, I can't reproduce this.

comment:3 Changed 8 years ago by stoecker

Resolution: irreproducible
Status: needinfoclosed

comment:4 Changed 6 years ago by Don-vip

Description: modified (diff)
Resolution: irreproducible
Status: closedreopened
Summary: exception on closeIllegalComponentStateException when closing JOSM

comment:5 Changed 6 years ago by Don-vip

Ticket #6981 has been marked as a duplicate of this ticket.

comment:6 Changed 6 years ago by Don-vip

Ticket #8295 has been marked as a duplicate of this ticket.

comment:7 Changed 6 years ago by Don-vip

Description: modified (diff)

comment:8 Changed 6 years ago by Don-vip

Cc: Gilbert54 skyper added

comment:9 Changed 6 years ago by Don-vip

Hi Gilbert,

Can you tell me more about your setup:

  • how many screens do you have ?
  • what layers did you have before closing ?
  • when you closed JOSM, was the relation editor open ? If yes, was it on the same screen as the main JOSM window ?

Thanks

comment:10 in reply to:  9 Changed 6 years ago by Gilbert54

Replying to Don-vip:

Hi Gilbert,

Can you tell me more about your setup:

  • how many screens do you have ?
  • what layers did you have before closing ?
  • when you closed JOSM, was the relation editor open ? If yes, was it on the same screen as the main JOSM window ?

Thanks

I have 2 screens. The main display is a 24" Dell (1920 x 1200), the secondary display, on the left side, is a 17" Fujitsu-Siemens (1280 x 1024). Both are connected to an ATI Radeon HD 2600 XT display controller.

I didn't pay particular attention to the state of the program when I closed it, but I'm pretty sure that the relation editor was closed before I quit JOSM. I normally have the Data layer and Bing Sat active. When the crash happened, JOSM was on my main display.

It doesn't happen often that the program crashes on exit. I think this is the 2nd or at most the 3rd time I see this. Fortunately - so far - I have not had a crash while editing.

Any particular info you want me to collect if it happens again ? Log files ?

comment:11 Changed 6 years ago by Don-vip

It should be enough, thanks :)

comment:12 Changed 6 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 5638/josm:

fix #6438 - Don't try to save window geometry if not showing on screen

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain dieterdreist.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.