Modify

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#8281 closed enhancement (fixed)

icons for scuba_diving and park_ride

Reported by: walterschloegl@… Owned by: Klumbumbus
Priority: normal Milestone: 14.10
Component: Internal mappaint style Version:
Keywords: Cc: Heartographix

Description (last modified by Don-vip)

There is an icon for sport=diving.
The same icon could be used for sport=scuba_diving.
diving and/or scuba_diving could be added to the sport menu.

There is an icon for parking=park_and_ride.
The same icon could be used for amenity=parking + park_ride=* (yes|train|bus|...) except park_ride=no.
Additionally to park_ride=yes/no please add the following values in dropdown list.
park_ride=bus/train/tram/metro/ferry/highway according to http://wiki.openstreetmap.org/wiki/Park_ride (highway is defacto)

Attachments (1)

scuba_dive.svg (1.4 KB) - added by skyper 6 years ago.
scuba diving icon. License PD from http://www.wpclipart.com

Download all attachments as: .zip

Change History (19)

comment:1 Changed 6 years ago by Don-vip

Component: CoreInternal mappaint style

comment:2 Changed 6 years ago by Don-vip

Ticket #9192 has been marked as a duplicate of this ticket.

comment:3 Changed 6 years ago by Don-vip

Description: modified (diff)

From #9192 for point 1:
we should:

comment:4 Changed 6 years ago by Don-vip

Cc: Heartographix added
Priority: trivialnormal

Changed 6 years ago by skyper

Attachment: scuba_dive.svg added

scuba diving icon. License PD from http://www.wpclipart.com

comment:5 Changed 6 years ago by skyper

Replying to Don-vip:

From #9192 for point 1:

  • render it with a better icon than we do now for sport=diving. I like this kind of icon: osmwiki:File:Diving-Spot.jpg (but not this terribly compressed jpeg version)

Here you go: scuba diving icon. License PD from http://www.wpclipart.com
Found it at www.wpclipart.com published under PD.

comment:6 in reply to:  5 Changed 6 years ago by skyper

Replying to skyper:

Replying to Don-vip:

From #9192 for point 1:

  • render it with a better icon than we do now for sport=diving. I like this kind of icon: osmwiki:File:Diving-Spot.jpg (but not this terribly compressed jpeg version)

Here you go: scuba diving icon. License PD from http://www.wpclipart.com
Found it at www.wpclipart.com published under PD.

If you prefer the version width boarder, it is also available at the site above.

Last edited 6 years ago by skyper (previous) (diff)

comment:7 Changed 5 years ago by Klumbumbus

Owner: changed from team to Klumbumbus
Status: newassigned

comment:8 Changed 5 years ago by Klumbumbus

icon see [o30732]

Last edited 5 years ago by Klumbumbus (previous) (diff)

comment:9 Changed 5 years ago by Klumbumbus

In 7630/josm:

see #8281 - deprecate sport=diving, add preset and mappaint style for sport=scuba_diving

comment:10 Changed 5 years ago by Klumbumbus

Milestone: 14.10

I will check the second part (parking) of this ticket in the next days.

comment:11 Changed 5 years ago by Klumbumbus

There is an icon for parking=park_and_ride.

According to wiki, I will deprecate this tag and remove the icon for this.

The same icon could be used for amenity=parking + park_ride=* (yes|train|bus|...) except park_ride=no.

I will add this.

Additionally to park_ride=yes/no please add the following values in dropdown list. park_ride=bus/train/tram/metro/ferry/highway according to http://wiki.openstreetmap.org/wiki/Park_ride (highway is defacto)

This is already done except for "highway". "highway" doesn't make sense in my eyes and is also used only 16 times.

comment:12 Changed 5 years ago by Klumbumbus

@team: when I replace an icon at https://trac.openstreetmap.org/browser/subversion/applications/share/map-icons/classic.small and the name is not the same like before should I simply delete the old icon or are there other projects which use these icons and maybe not notice the change?

(The reason that the new name is not the same like the old name can either be that the file extension changed from png to svg or like in this case it changed from diving to scuba_diving.)

Last edited 5 years ago by Klumbumbus (previous) (diff)

comment:13 Changed 5 years ago by stoecker

There was another users of these icons in the past. Not sure about today anymore.

comment:14 Changed 5 years ago by Klumbumbus

I asked TomH. He has also no idea if other projects use the icons. I checked the changeset comments in the osm svn which contain the word "icon". I couldn't find a changeset in the last 2 years, which is related to these icons but not related to josm. So I assume, that JOSM is the only project and I will delete the old icons when I replace them by new ones to avoid a lot of unused/doubled icons.

comment:15 Changed 5 years ago by Klumbumbus

park_ride icon: [o30752]

Last edited 5 years ago by Klumbumbus (previous) (diff)

comment:16 Changed 5 years ago by Klumbumbus

Resolution: fixed
Status: assignedclosed

In [7635]:

fixes #8281 - deprecate parking=park_and_ride in favor of amenity=parking park_ride=yes (updated validator and mappaint style)

comment:18 Changed 5 years ago by Don-vip

Pro tip: You can edit your commit message afterwards if you mispelled the ticket number, then the comment is automatically added, like if it was right from the beginning :)

comment:19 Changed 5 years ago by Klumbumbus

Oh nice, thanks.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Klumbumbus.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.