Modify

Opened 7 years ago

Closed 7 years ago

#8223 closed defect (duplicate)

Josm reported crash

Reported by: Cottaer Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

got this message during upload of new data, was asked to report this message, don't know what happened, first time this issue occured; Josm still seems to work, but will restart of course

What steps will reproduce the problem?

  1. sorry, don't know

What is the expected result?

no more crashes ;-)

What happens instead?

hopefully no more crashes ;-)

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-11-10 02:31:13
Last Changed Author: bastiK
Revision: 5576
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-11-09 21:16:38 +0100 (Fri, 09 Nov 2012)
Last Changed Rev: 5576

Identification: JOSM/1.5 (5576 de)
Memory Usage: 475 MB / 494 MB (307 MB allocated, but free)
Java version: 1.6.0_29, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: DirectUpload (28807)
Plugin: buildings_tools (28891)
Plugin: editgpx (28807)
Plugin: openstreetbugs (28807)
Plugin: reverter (28820)
Plugin: turnrestrictions (28807)
Plugin: undelete (28807)
Plugin: utilsplugin2 (28807)

org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Way id=192978131 version=1 MVT nodes=[{Node id=158341608 version=3 MV lat=41.32388174144398,lon=-110.40065758234356}, {Node id=2035111884 version=1 MV lat=41.324105690756085,lon=-110.40118106031045}]}
	at org.openstreetmap.josm.data.osm.OsmPrimitive.checkDataset(OsmPrimitive.java:325)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:893)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:914)
	at org.openstreetmap.josm.gui.dialogs.properties.PropertiesDialog.selectionChanged(PropertiesDialog.java:1110)
	at org.openstreetmap.josm.gui.dialogs.properties.PropertiesDialog.updateSe

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by skyper

Please, have a look if the upload did work or was it interrupted before upload. If possible please attach the file you tried to upload.

Thanks

Similar to #7881.

comment:2 Changed 7 years ago by rickmastfan67

Cottaer, while this will not fix your problem, you should really upgrade your copy of Java. You are currently running a really out-of-date version that hackers are actively attacking in Windows. The current version of Java is 1.7.09 (you're running 1.6.29), which can be downloaded from here: http://www.java.com/en/download/manual.jsp

Just remember to un-install the old version first before installing the new one to prevent any parts of the old install from staying on your system leaving you open to an attack. ;)

Last edited 7 years ago by rickmastfan67 (previous) (diff)

comment:3 Changed 7 years ago by anonymous

The upload seems to have finished [1]. Josm said, there was nothing to upload left after this report. Also the way it reported seems to be fine [2]. And thanks for the reminder about Java, I do know about it, I have disabled Java in all browsers since long.

[1] http://www.openstreetmap.org/browse/changeset/14048245
[2] http://www.openstreetmap.org/browse/way/192978131

comment:4 Changed 7 years ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #5783.
Java version should not be a problem except of maybe security updates and bug fixes in the Windows version. On Debian stable I still run version 1.6.20.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.