Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8172 closed defect (fixed)

building_tools plugin crashes at start of JOSM

Reported by: rickmastfan67 Owned by: bastiK
Priority: blocker Milestone:
Component: Plugin buildings_tools Version: latest
Keywords: Cc:

Description

Just upgraded from [5545] to [5552] and when I started, the building_tools plugin crashed right away. Here's what showed up in the Command Line when starting it in Windows 7 x64 as I didn't get a normal bug report crash:

Skipping plugin update after JOSM upgrade. Automatic update at startup is disabl
ed.
Could not load tool definition dumbutils/replacegeometry
loading plugin 'undelete' (version 28807)
loading plugin 'openstreetbugs' (version 28807)
loading plugin 'mirrored_download' (version 28807)
loading plugin 'mapdust' (version 28807)
loading plugin 'reverter' (version 28820)
RemoteControl: adding command "revert_changeset" (handled by RevertChangesetHand
ler)
java.lang.NoClassDefFoundError: org/openstreetmap/josm/data/projection/Mercator
        at buildings_tools.BuildingsToolsPlugin.<clinit>(BuildingsToolsPlugin.ja
va:14)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Unknown Source)
        at org.openstreetmap.josm.plugins.PluginInformation.loadClass(PluginInfo
rmation.java:298)
        at org.openstreetmap.josm.plugins.PluginHandler.loadPlugin(PluginHandler
.java:501)
        at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandle
r.java:562)
        at org.openstreetmap.josm.plugins.PluginHandler.loadLatePlugins(PluginHa
ndler.java:601)
        at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:
348)
Caused by: java.lang.ClassNotFoundException: org.openstreetmap.josm.data.project
ion.Mercator
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        ... 8 more
loading plugin 'OpeningHoursEditor' (version 28656)
loading plugin 'utilsplugin2' (version 28807)
loading plugin 'turnrestrictions' (version 28807)
loading plugin 'measurement' (version 28807)
RemoteControl::Accepting connections on port 8111

When looking at the changesets between the two latest builds, I'm going to take a stab and guess that [5546] or [5548] caused this plugin to break.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-11-02 02:31:11
Last Changed Author: bastiK
Revision: 5552
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-11-01 21:47:57 +0100 (Thu, 01 Nov 2012)
Last Changed Rev: 5552

Identification: JOSM/1.5 (5552 en)
Memory Usage: 154 MB / 2730 MB (92 MB allocated, but free)
Java version: 1.7.0_09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7

Plugin: OpeningHoursEditor (28656)
Plugin: buildings_tools
Plugin: mapdust (28807)
Plugin: measurement (28807)
Plugin: mirrored_download (28807)
Plugin: openstreetbugs (28807)
Plugin: reverter (28820)
Plugin: turnrestrictions (28807)
Plugin: undelete (28807)
Plugin: utilsplugin2 (28807)

Attachments (0)

Change History (10)

comment:1 Changed 7 years ago by malenki

The plugins magicshop, opendata and surveyor2 are also affected.

(edited since some plugins don't load because of an other issue obviously)

Last edited 7 years ago by malenki (previous) (diff)

comment:2 Changed 7 years ago by bastiK

Owner: changed from Upliner to bastiK
Status: newassigned

comment:3 Changed 7 years ago by rickmastfan67

bastiK, I see you released an update for the buildings_tools plugin earlier today with the min version set at [5548]. So, I start JOSM and work to get my copy of that plugin updated. The update downloads correctly. Then I close and restart JOSM and it still crashes at the start using [5552]. :(

Skipping plugin update after JOSM upgrade. Automatic update at startup is disabled.
Could not load tool definition dumbutils/replacegeometry
loading plugin 'undelete' (version 28807)
loading plugin 'openstreetbugs' (version 28807)
loading plugin 'mirrored_download' (version 28807)
loading plugin 'mapdust' (version 28807)
loading plugin 'reverter' (version 28820)
RemoteControl: adding command "revert_changeset" (handled by RevertChangesetHandler)
java.lang.NoClassDefFoundError: org/openstreetmap/josm/data/projection/ProjectionInfo
        at buildings_tools.BuildingsToolsPlugin.<clinit>(BuildingsToolsPlugin.java:15)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Unknown Source)
        at org.openstreetmap.josm.plugins.PluginInformation.loadClass(PluginInformation.java:298)
        at org.openstreetmap.josm.plugins.PluginHandler.loadPlugin(PluginHandler.java:501)
        at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandler.java:562)
        at org.openstreetmap.josm.plugins.PluginHandler.loadLatePlugins(PluginHandler.java:601)
        at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:348)
Caused by: java.lang.ClassNotFoundException: org.openstreetmap.josm.data.projection.ProjectionInfo
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        ... 8 more
loading plugin 'OpeningHoursEditor' (version 28656)
loading plugin 'utilsplugin2' (version 28807)
loading plugin 'turnrestrictions' (version 28807)
loading plugin 'measurement' (version 28807)
RemoteControl::Accepting connections on port 8111

This version of the plugin crashed in a different place compared to the last one. Crashed at "buildings_tools.BuildingsToolsPlugin.<clinit>(BuildingsToolsPlugin.java:15)" when the older version crashed at "buildings_tools.BuildingsToolsPlugin.<clinit>(BuildingsToolsPlugin.java:14)".

comment:4 Changed 7 years ago by bastiK

In 5554/josm:

join ProjectionInfo and Projections

the first is not referenced in core code (therefore removed by server build) but needed in plugins (see #8172)

comment:5 Changed 7 years ago by bastiK

In [o28887], [o28888], [o28889], [o28891].

(Min. JOSM version: r5554)

@malenki: surveyor2 compiles, can you list the error (from console window). magicshop is external, so you may contact the author, if you like.

comment:6 Changed 7 years ago by Don-vip

In 5556/josm:

see #8172 - fix JUnit tests

comment:7 Changed 7 years ago by Don-vip

The Swiss grid projection test fails, but I don't know if it's related to the recent changes or if the test was already failing before.

comment:8 in reply to:  7 Changed 7 years ago by bastiK

Replying to Don-vip:

The Swiss grid projection test fails, but I don't know if it's related to the recent changes or if the test was already failing before.

Thanks for the fixes!

Swiss grid projection test results are unchanged. You can provide the option suppressPermanentFailure=yes to make it pass (increases the epsilon). E.g.

$ java -cp $TESTCP -DsuppressPermanentFailure=yes org.junit.runner.JUnitCore org.openstreetmap.josm.data.projection.SwissGridTest

comment:9 Changed 7 years ago by bastiK

Resolution: fixed
Status: assignedclosed

Please reopen, if there are still problems!

comment:10 in reply to:  5 Changed 7 years ago by malenki

Replying to bastiK:

@malenki: surveyor2 compiles, can you list the error (from console window). magicshop is external, so you may contact the author, if you like.

Sorry for the late reply. Now tested with r5576: There are no issues with surveyor2 anymore.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain bastiK.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.