Modify

Opened 7 years ago

Closed 6 years ago

#8047 closed defect (fixed)

IndexOutOfBoundsException in save/upload dialog after deleting a layer

Reported by: mcheck Owned by: team
Priority: normal Milestone: 14.04
Component: Core Version:
Keywords: edt violation Cc:

Description (last modified by Don-vip)

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-09-08 01:31:06
Last Changed Author: Don-vip
Revision: 5504
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-09-07 23:11:08 +0200 (Fri, 07 Sep 2012)
Last Changed Rev: 5504

Identification: JOSM/1.5 (5504 it)
Memory Usage: 201 MB / 432 MB (100 MB allocated, but free)
Java version: 1.7.0_07, Oracle Corporation, Java HotSpot(TM) Server VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: AddrInterpolation (28541)
Plugin: FastDraw (28656)
Plugin: ImportImagePlugin (28656)
Plugin: PicLayer (28660)
Plugin: SimplifyArea (28656)
Plugin: buildings_tools (28656)
Plugin: continuosDownload (28565)
Plugin: dataimport (28656)
Plugin: download_along (28656)
Plugin: mirrored_download (28656)
Plugin: multipoly-convert (28656)
Plugin: namemanager (28541)
Plugin: print (28656)
Plugin: proj4j (28495)
Plugin: reverter (28656)
Plugin: tageditor (28656)
Plugin: tagging-preset-tester (28566)
Plugin: terracer (28656)
Plugin: undelete (28541)
Plugin: walkingpapers (28541)
Plugin: waydownloader (28492)
Plugin: wayselector (28541)

java.lang.IndexOutOfBoundsException: Index: 3, Size: 3
	at java.util.ArrayList.rangeCheck(ArrayList.java:604)
	at java.util.ArrayList.get(ArrayList.java:382)
	at java.awt.Container.createHierarchyEvents(Container.java:1434)
	at java.awt.Container.createHierarchyEvents(Container.java:1434)
	at java.awt.Container.createHierarchyEvents(Container.java:1434)
	at java.awt.Container.createHierarchyEvents(Container.java:1434)
	at java.awt.Container.createHierarchyEvents(Container.java:1434)
	at java.awt.Container.createHierarchyEvents(Container.java:1434)
	at java.awt.Component.hide(Component.java:1689)
	at java.awt.Window.hide(Window.java:1116)
	at java.awt.Dialog.hide(Dialog.java:1174)
	at java.awt.Component.show(Component.java:1653)
	at java.awt.Component.setVisible(Component.java:1603)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1003)
	at org.openstreetmap.josm.gui.io.SaveLayersDialog.closeDialog(SaveLayersDialog.java:290)
	at org.openstreetmap.josm.gui.io.SaveLayersDialog$SaveAndUploadTask.run(SaveLayersDialog.java:572)
	at java.lang.Thread.run(Thread.java:722)

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by Don-vip

Description: modified (diff)

comment:2 Changed 7 years ago by Don-vip

Ticket #8600 has been marked as a duplicate of this ticket.

comment:3 Changed 6 years ago by Don-vip

Keywords: edt violation added
Milestone: 14.04
Summary: this error deleting a osm littel layer: osm was asking to load itIndexOutOfBoundsException in save/upload dialog after deleting a layer

comment:4 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 6965/josm:

fix #8047 - fix EDT violation in save/upload dialog

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.