Modify

Opened 9 years ago

Closed 9 years ago

#7998 closed defect (duplicate)

NPE after download of data

Reported by: adjuva@… Owned by: team
Priority: normal Milestone:
Component: Plugin measurement Version: latest
Keywords: NPE Cc:

Description

To create the error:

No NPE after deactivating the measurement plugin and restarting JOSM.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-08-25 01:31:08
Last Changed Author: bastiK
Revision: 5475
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-08-24 13:24:55 +0200 (Fri, 24 Aug 2012)
Last Changed Rev: 5475

Identification: JOSM/1.5 (5475 de)
Memory Usage: 145 MB / 241 MB (29 MB allocated, but free)
Java version: 1.6.0_33, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows XP

Dataset consistency test:
[SEARCH WAYS] {Way id=142109298 version=1 VT nodes=[
  {Node id=1555420767 version=0 IV },
  {Node id=1555420729 version=0 IV },
  {Node id=1555420772 version=0 IV },
  {Node id=1555420701 version=0 IV }, 
  {Node id=1555420773 version=0 IV },
  {Node id=1555420809 version=0 IV },
  {Node id=1555420810 version=0 IV },
  {Node id=1555420699 version=0 IV }, 
  {Node id=1555420747 version=0 IV }, 
  {Node id=1555420824 version=0 IV }, 
  {Node id=1555420780 version=0 IV },
  {Node id=1555420658 version=0 IV },
  {Node id=1555420853 version=0 IV },
  {Node id=1555420778 version=0 IV }, 
  {Node id=1555420753 version=0 IV },
  {Node id=1555420768 version=0 IV }, 
  {Node id=1555420812 version=0 IV },
  {Node id=1555420742 version=0 IV }, 
  {Node id=1555420767 version=0 IV }]} not found using Dataset.searchWays()


Plugin: OpeningHoursEditor (28477)
Plugin: PicLayer (28559)
Plugin: RoadSigns (27868)
Plugin: download_along (28412)
Plugin: measurement (28412)
Plugin: mirrored_download (28418)
Plugin: public_transport (28412)
Plugin: reltoolbox (28412)
Plugin: restart (28438)
Plugin: reverter (28535)
Plugin: tagging-preset-tester (28412)
Plugin: todo (28330)
Plugin: utilsplugin2 (28556)
Plugin: waydownloader (28412)
Plugin: wayselector (28412)
Plugin: wikipedia (28506)

java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.measurement.MeasurementDialog$2.selectionChanged(MeasurementDialog.java:140)
	at org.openstreetmap.josm.data.osm.DataSet.fireSelectionChanged(DataSet.java:442)
	at org.openstreetmap.josm.data.osm.DataSet.setSelected(DataSet.java:615)
	at org.openstreetmap.josm.data.osm.DataSet.setSelected(DataSet.java:626)
	at org.openstreetmap.josm.actions.SelectAllAction.actionPerformed(SelectAllAction.java:23)
	at javax.swing.SwingUtilities.notifyAction(Unknown Source)
	at javax.swing.JComponent.processKeyBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireKeyboardAction(Unknown Source)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(Unknown Source)
	at javax.swing.JComponent.processKeyBindings(Unknown Source)
	at javax.swing.JComponent.processKeyEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$000(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$2.run(Unknown Source)
	at java.awt.EventQueue$2.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (1)

comment:1 Changed 9 years ago by AlfonZ

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7987.
Please update measurement plugin to latest version 28589.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.