Modify

Opened 9 years ago

Closed 9 years ago

#7996 closed defect (duplicate)

buildings_tools: exception at finishing object

Reported by: malenki Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: template_report buildings_tools Cc:

Description

IMHO Important: up to r5461 the exception does not occur. With the next unstable version r5467 it shows up.

What steps will reproduce the problem?

  1. run JOSM
  2. open new datalayer
  3. draw a rectangle using buildings_tools

What is the expected result?

A rectangle-shaped object.

What happens instead?

See exception below.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-08-23 01:31:06
Last Changed Author: Don-vip
Revision: 5472
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-08-23 02:25:01 +0200 (Thu, 23 Aug 2012)
Last Changed Rev: 5472

Identification: JOSM/1.5 (5472 de)
Memory Usage: 206 MB / 1719 MB (95 MB allocated, but free)
Java version: 1.6.0_33, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: FastDraw (28412)
Plugin: FixAddresses (28412)
Plugin: OpeningHoursEditor (28477)
Plugin: PicLayer (28559)
Plugin: buildings_tools (28529)
Plugin: contourmerge (1003)
Plugin: download_along (28412)
Plugin: editgpx (28412)
Plugin: ext_tools (28412)
Plugin: imageryadjust (28412)
Plugin: jts (28415)
Plugin: lakewalker (28412)
Plugin: mapdust (28412)
Plugin: measurement (28589)
Plugin: mirrored_download (28418)
Plugin: opendata (28441)
Plugin: openstreetbugs (28412)
Plugin: openvisible (28412)
Plugin: reltoolbox (28412)
Plugin: reverter (28535)
Plugin: tag2link (28599)
Plugin: tageditor (28412)
Plugin: terracer (28412)
Plugin: turnrestrictions (28412)
Plugin: undelete (28501)
Plugin: utilsplugin2 (28556)
Plugin: waydownloader (28412)
Plugin: wayselector (28412)

java.lang.NoSuchMethodError: org.openstreetmap.josm.data.preferences.BooleanProperty.get()Z
	at buildings_tools.Building.create(Building.java:302)
	at buildings_tools.DrawBuildingAction.drawingFinish(DrawBuildingAction.java:306)
	at buildings_tools.DrawBuildingAction.drawingAdvance(DrawBuildingAction.java:297)
	at buildings_tools.DrawBuildingAction.mouseReleased(DrawBuildingAction.java:352)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$000(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$2.run(Unknown Source)
	at java.awt.EventQueue$2.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Sourc

Attachments (0)

Change History (1)

comment:1 Changed 9 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7995.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.