Modify

Opened 7 years ago

Closed 7 years ago

#7995 closed defect (fixed)

Buildin plugin crash after starting draw building when i click second point to create it

Reported by: anonymous Owned by: Don-vip
Priority: major Milestone:
Component: Core Version: latest
Keywords: buildings plugin crash Cc:

Description (last modified by Don-vip)

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-08-23 01:31:06
Last Changed Author: Don-vip
Revision: 5472
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-08-23 02:25:01 +0200 (Thu, 23 Aug 2012)
Last Changed Rev: 5472

Identification: JOSM/1.5 (5472 it)
Memory Usage: 231 MB / 1820 MB (66 MB allocated, but free)
Java version: 1.6.0_26, Sun Microsystems Inc., Java HotSpot(TM) Server VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: AddrInterpolation (28014)
Plugin: FastDraw (28412)
Plugin: FixAddresses (28412)
Plugin: HouseNumberTaggingTool (28412)
Plugin: ImageWayPoint (27852)
Plugin: ImportImagePlugin (28412)
Plugin: OpeningHoursEditor (28477)
Plugin: PicLayer (28559)
Plugin: RoadSigns (27868)
Plugin: SimplifyArea (27905)
Plugin: buildings_tools (28529)
Plugin: continuosDownload (28565)
Plugin: contourmerge (1003)
Plugin: dataimport (28412)
Plugin: download_along (28412)
Plugin: editgpx (28412)
Plugin: ext_tools (28412)
Plugin: graphview (28412)
Plugin: imageryadjust (28412)
Plugin: importvec (28412)
Plugin: irsrectify (28412)
Plugin: lakewalker (28412)
Plugin: mirrored_download (28418)
Plugin: multipoly-convert (28412)
Plugin: namemanager (28412)
Plugin: openstreetbugs (28412)
Plugin: osmarender (28412)
Plugin: pbf (28412)
Plugin: pdfimport (28448)
Plugin: photo_geotagging (28412)
Plugin: plastic_laf (26605)
Plugin: print (28412)
Plugin: proj4j (28412)
Plugin: public_transport (28412)
Plugin: reltoolbox (28412)
Plugin: reverter (28535)
Plugin: scripting (30000)
Plugin: tageditor (28412)
Plugin: tagging-preset-tester (28566)
Plugin: terracer (28412)
Plugin: utilsplugin2 (28556)
Plugin: walkingpapers (28412)
Plugin: wms-turbo-challenge2 (28412)

java.lang.NoSuchMethodError: org.openstreetmap.josm.data.preferences.BooleanProperty.get()Z
	at buildings_tools.Building.create(Building.java:302)
	at buildings_tools.DrawBuildingAction.drawingFinish(DrawBuildingAction.java:306)
	at buildings_tools.DrawBuildingAction.drawingAdvance(DrawBuildingAction.java:297)
	at buildings_tools.DrawBuildingAction.mouseReleased(DrawBuildingAction.java:352)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:273)
	at java.awt.Component.processMouseEvent(Component.java:6288)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
	at java.awt.Component.processEvent(Component.java:6053)
	at java.awt.Container.processEvent(Container.java:2041)
	at java.awt.Component.dispatchEventImpl(Component.java:4651)
	at java.awt.Container.dispatchEventImpl(Container.java:2099)
	at java.awt.Component.dispatchEvent(Component.java:4481)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4577)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
	at java.awt.Container.dispatchEventImpl(Container.java:2085)
	at java.awt.Window.dispatchEventImpl(Window.java:2478)
	at java.awt.Component.dispatchEvent(Component.java:4481)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:643)
	at java.awt.EventQueue.access$000(EventQueue.java:84)
	at java.awt.EventQueue$1.run(EventQueue.java:602)
	at java.awt.EventQueue$1.run(EventQueue.java:600)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:98)
	at java.awt.EventQueue$2.run(EventQueue.java:616)
	at java.awt.EventQueue$2.run(EventQueue.java:614)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:613)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (8)

comment:1 Changed 7 years ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #7982.

comment:2 Changed 7 years ago by Don-vip

Priority: normalmajor
Resolution: duplicate
Status: closedreopened
Version: latest

I don't think it is a duplicate, this is not the same method. I'll fix it tonight.

comment:3 Changed 7 years ago by Don-vip

Owner: changed from team to Don-vip
Status: reopenednew

comment:4 Changed 7 years ago by Don-vip

Description: modified (diff)

comment:5 Changed 7 years ago by Don-vip

Ticket #7996 has been marked as a duplicate of this ticket.

comment:6 in reply to:  2 Changed 7 years ago by skyper

Replying to Don-vip:

I don't think it is a duplicate, this is not the same method. I'll fix it tonight.

Sorry, seems to be the same initial change r5464. This time file trunk/src/org/openstreetmap/josm/data/preferences/BooleanProperty.java line 21.

comment:7 Changed 7 years ago by Don-vip

It is, you're perfectly right. By "not a duplicate" I only meant there was still something to do, the ticket could not just be closed as it (but we also could have reopened the other one, I agree)

comment:8 Changed 7 years ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o28603], [o28605], [o28606]. If you're using building_tools, alignways or routing plugin, you just have to update it.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.