Modify

Opened 7 years ago

Closed 7 years ago

#7920 closed defect (fixed)

Columbus V-900 Vox-files are not displayed on JOSM screen

Reported by: meppen7 Owned by: meppen7
Priority: normal Milestone:
Component: Plugin columbuscsv Version: latest
Keywords: V-900, VOX-Files Cc:

Description

VOX-Files recorded with the datalogger Columbus V-900 are not displayed together with the CSV-data on JOSM screen.
JOSM Version 5388

Attachments (0)

Change History (20)

comment:1 Changed 7 years ago by skyper

Owner: changed from OliverW to meppen7
Status: newneedinfo

Works for me. Test with ticket:6912:columbus900track.zip.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-08-26 01:31:13
Last Changed Author: stoecker
Revision: 5477
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-08-25 21:04:25 +0200 (Sat, 25 Aug 2012)
Last Changed Rev: 5477

Identification: JOSM/1.5 (5477 en)
Memory Usage: 106 MB / 883 MB (25 MB allocated, but free)
Java version: 1.6.0_24, Sun Microsystems Inc., OpenJDK 64-Bit Server VM
Operating system: Linux

Plugin: ColumbusCSV (28043)

Please, add more information (operating system, JOSM and Java version ...). A sample (gpx-track+audio) would be useful,too.

comment:2 Changed 7 years ago by anonymous

Works for me too with test-file columbus900track.zip after deleting the directory JOSM in Appdata/Roaming.

JOSM ver 5477
Plugin ColumbusCSV:Version28043
OP: Windows Vista 32bit
Java Version: Java 6 update 33

comment:3 in reply to:  2 Changed 7 years ago by anonymous

Replying to anonymous:

Works for me too with test-file columbus900track.zip after deleting the directory JOSM in Appdata/Roaming.

JOSM ver 5477
Plugin ColumbusCSV:Version28043
OP: Windows Vista 32bit
Java Version: Java 6 update 33

meppen7

comment:4 Changed 7 years ago by skyper

Resolution: invalid
Status: needinfoclosed

comment:5 Changed 7 years ago by Don-vip

Resolution: invalidduplicate

In fact, duplicate of #8007

comment:7 Changed 7 years ago by Frankl2009

I have the same problem (only discovered today; it must be recent) and have not yet found a way to resolve it. I do not run the opendata plugin referenced in #8007, and it is not clear whether it is a duplicate problem. The problem arises using JOSM version 5608 (and also if I go back to version 5576). Java version 1.6.0_38 (but the same happens with Java ver 7.11). Columbus CSV version 29178.
Running on Win XP Pro SP3 and up to date on all MS (security) updates.

comment:8 Changed 7 years ago by Frankl2009

Discovered the updated ColumbusCSV version 29179 referenced at #8007. This does not (yet) show in JOSM Plugins when requesting Update plug-ins. Downloaded and installed version 29179 manually in Plugin folder. Note: this shows in the JOSM Plugin list as local: 29009. The problem does not go away (still only the gps trace but voice wave files are not loaded into JOSM).
Updating JOSM to version 5608 does not resolve the problem.
Removing Java 6-38 and installing Java 7-11 does not resolve the problem.

Last edited 7 years ago by Don-vip (previous) (diff)

comment:9 in reply to:  8 Changed 7 years ago by skyper

Replying to Frankl2009:

Discovered the updated ColumbusCSV version 29179 referenced at #8007. This does not (yet) show in JOSM Plugins when requesting Update plug-ins. Downloaded and installed version 29179 manually in Plugin folder. Note: this shows in the JOSM Plugin list as local: 29009. The problem does not go away (still only the gps trace but voice wave files are not loaded into JOSM).
Updating JOSM to version 5608 does not resolve the problem.
Removing Java 6-38 and installing Java 7-11 does not resolve the problem.

Problem is the plugin and not core or java.

This is all related to #8007 which is not fixed. Gonna reopen. Please, comment on #8007

You could try it without opendata.

Last edited 7 years ago by Don-vip (previous) (diff)

comment:10 Changed 7 years ago by OliverW

Now I'm confused. The problem stated above has nothing to do with #8007.

#8007 solves (or was at least intended to solve) the conflict with the opendata plugin.

#7920 describes a problem with vox import. So I tested the new version with the ZIP file mentioned above and it worked fine on my box with JOSM 5608, Java 1.6.

Please review your assignments.

comment:11 in reply to:  10 Changed 7 years ago by skyper

Replying to oliverw:

Now I'm confused. The problem stated above has nothing to do with #8007.

#8007 solves (or was at least intended to solve) the conflict with the opendata plugin.

#7920 describes a problem with vox import. So I tested the new version with the ZIP file mentioned above and it worked fine on my box with JOSM 5608, Java 1.6.

Please review your assignments.

Sorry, my fault. Should have read more carefully. Do not have any problems either.

comment:12 Changed 7 years ago by anonymous

Thanks for the response, Oliver (and skyper). I'm not sure anything significant has changed on my XP Pro box since the beginning of January (when I last used JOSM with ColumbusCSV successfully). But I'll review MS security and other updates since then and see if anything obvious shows up which might have caused this change. But I fear that this bug report cannot be considered closed yet (and it may not have anything to do with the csv extension clash).

comment:13 Changed 7 years ago by Frankl2009

One additional point. I switched columbuscsv.import.showSummary to true (and added columbuscsv.warn.missingAudio and columbuscsv.warn.conversionErrors). On importing, I get a pop-up with a message such as: Information: Imported 1326 track points and 46 way points (45 with audio, 0 rescued). The audio markers do not appear in the main JOSM pane nor is there an entry for them in the Layers window. This worked previously. Where could I find a previous version of the plugin to test?

comment:14 Changed 7 years ago by skyper

@Frankl2009:

  • You can reopen any ticket by yourself (Modify Ticket).
  • Did you try it with the example mentioned above ?
  • Please, attach an example that does not work for you.
  • Please, add some information about your system (wiki:Help/Action/ShowStatusReport).

comment:15 Changed 7 years ago by anonymous

Thanks. Using the example, the problem remains. The files which do not show all used to work (and have been used previously to input data in JOSM). The data files are not the issue. I would like to roll back to a previous version of the plugin to test: where can I find this?

The status block follows. I removed all other plugins while testing. Note this is currently Java 1.7.0_11 but it exhibits the same problem under Java version 1.6

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-11-29 02:31:07
Last Changed Author: stoecker
Revision: 5608
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-11-28 23:47:46 +0100 (Wed, 28 Nov 2012)
Last Changed Rev: 5608

Identification: JOSM/1.5 (5608 en_GB)
Memory Usage: 64 MB / 494 MB (22 MB allocated, but free)
Java version: 1.7.0_11, Oracle Corporation, Java HotSpot(TM) Client VM
Operating system: Windows XP

Plugin: ColumbusCSV (29178)

Thanks for your help.

comment:16 Changed 7 years ago by Frankl2009

Resolution: duplicate
Status: closedreopened

comment:17 in reply to:  15 ; Changed 7 years ago by skyper

Replying to anonymous:

Thanks. Using the example, the problem remains. The files which do not show all used to work (and have been used previously to input data in JOSM). The data files are not the issue.

Looks like a local problem with your settings and/or OS, as Oliver and myself have no problems.
Did you try it with a fresh, empty preference directory ? You could rename or delete it or use the command line option to set it on start up (see wiki:HowTo#Howtoresetthepreferences).

I would like to roll back to a previous version of the plugin to test: where can I find this?

Obviously, you can use svn and compile it yourself, or use a JOSM version prior 5000 but I doubt that we gonna get much new information of it.

Good luck

comment:18 in reply to:  17 ; Changed 7 years ago by Frankl2009

Replying to skyper:

Replying to anonymous:

I would like to roll back to a previous version of the plugin to test: where can I find this?

Obviously, you can use svn and compile it yourself, or use a JOSM version prior 5000 but I doubt that we gonna get much new information of it.

Good luck

I meant a previous version of the ColumbusCSV plugin. I can only find the current version and what to see whether an earlier version resolves the problem. Thanks.

comment:19 in reply to:  18 ; Changed 7 years ago by skyper

Replying to Frankl2009:

Replying to skyper:

Replying to anonymous:

I would like to roll back to a previous version of the plugin to test: where can I find this?

Obviously, you can use svn and compile it yourself, or use a JOSM version prior 5000 but I doubt that we gonna get much new information of it.

Good luck

Did you try it ?

I meant a previous version of the ColumbusCSV plugin. I can only find the current version and what to see whether an earlier version resolves the problem. Thanks.

That is what I am talking about. The .jar file of the plugin is usually replaced but you can get it from svn. Try something like this:
https://trac.openstreetmap.org/browser/subversion/applications/editors/josm/dist/ColumbusCSV.jar?rev=29009

Current version of plugin depends on JOSM version 50**, e.g. lower JOSM version will pull lower plugin version.

comment:20 in reply to:  19 Changed 7 years ago by anonymous

Replying to skyper:

I meant a previous version of the ColumbusCSV plugin. I can only find the current version and what to see whether an earlier version resolves the problem. Thanks.

That is what I am talking about. The .jar file of the plugin is usually replaced but you can get it from svn. Try something like this:
https://trac.openstreetmap.org/browser/subversion/applications/editors/josm/dist/ColumbusCSV.jar?rev=29009

Current version of plugin depends on JOSM version 50**, e.g. lower JOSM version will pull lower plugin version.

Thanks. The link was helpful. I downloaded the ColumbusCSV.jar and placed it in the appropriate directory. It showed in Preferences | Plugins as local: 28043.
Now the Vox files showed on the main panel and there was a "Markers from" entry in the Layers panel. I could play back the recordings.
I updated the plugin to the current ColumbusCSV .jar via Preferences | Plugins | Update plug-ins and restarted JOSM. This ALSO now worked. (Note: I had done this previously, but clearly something had not yet taken.)
So I am now up to date on JOSM (5608) and the ColumbusCSV plugin (29210). But I have no idea what was wrong.
Thanks for your help!

comment:21 Changed 7 years ago by skyper

Resolution: fixed
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain meppen7.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.