Modify

Opened 5 years ago

Closed 5 years ago

#7906 closed enhancement (fixed)

JOSM changes after ODbL license switch

Reported by: Don-vip Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: license odbl ct contributor terms licensechange Cc:

Description

As the license switch is immiment, there are some things to do in JOSM.

I have already closed all remaining tickets affected to licensechange plugin as it is obvious they will not be fixed (it is not even possible to reproduce many of them since the redaction process have ended).

The plugin itself may be deprecated.

There is another question regarding all CT support. I don't see any reason to keep this information in JOSM. Is it safe to remove it entirely ? (CT display in history, "Load CT" in users dialog, etc.)

Attachments (0)

Change History (10)

comment:1 Changed 5 years ago by mrwojo

Passive removal of odbl tags may also show up on JOSM's radar, depending on the outcome of discussion:

http://lists.openstreetmap.org/pipermail/tagging/2012-July/010902.html

comment:2 Changed 5 years ago by stoecker

A big yes about the removal of these features, but not yet. 1-2 months don't do any harm and maybe there is still need for some stuff.

comment:3 Changed 5 years ago by rickmastfan67

I think the CT display in the History might be a good idea to keep. Sometimes, decliners names will still show up in the history. Especially if they only deleted a node or two from a way and nothing else.

comment:4 Changed 5 years ago by stoecker

As there are no real issues I would say next release end of August should be stripped of ODBL/ct stuff.

comment:5 Changed 5 years ago by bastiK

The license change isn't over, as the OSMF hasn't published any data under the ODbL. But anyway I agree we can drop this code now.

comment:6 Changed 5 years ago by Don-vip

Ticket #7988 has been marked as a duplicate of this ticket.

comment:7 Changed 5 years ago by Don-vip

The bot is running again under a different account:

http://www.openstreetmap.org/user/pnorman%20redaction%20revert/

I tend to prefer to wait for official OSMF announcement that the redaction has been technically completed before removing this code.

comment:8 Changed 5 years ago by Don-vip

OK this is finished now:
http://lists.openstreetmap.org/pipermail/osmf-talk/2012-September/001752.html

I'm going to remove CT stuff.

comment:9 Changed 5 years ago by Don-vip

In 5495/josm:

see #7906 - Remove ODbL/CT stuff

comment:10 Changed 5 years ago by stoecker

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.