Modify

Opened 8 years ago

Closed 6 years ago

Last modified 2 years ago

#7802 closed defect (fixed)

Zoom in with "+" does not work

Reported by: Zverikk Owned by: team
Priority: minor Milestone: 13.12
Component: Core Version: latest
Keywords: zoom keyboard Cc: jphilipz

Description

When "-" (regular key, not numpad) key is pressed, the map is zoomed out. But "+" (or Shift-"+") does not do anything. It should zoom the map in, to be consistent with "-" key behaviour.

Also (a comment, not related to the ticket): zooming keys in download windows and in JOSM do not match: in former "+/-" do not work at all, but "Ctrl+Up/Down" zooms a map. In JOSM Ctrl+Up/Down moves the map vertically.

Attachments (0)

Change History (14)

comment:1 Changed 7 years ago by Manu1400

Priority: normalminor

comment:2 Changed 7 years ago by Manu1400

Reproductible : yes (on my AZERTY french keyboard)

Last edited 7 years ago by Manu1400 (previous) (diff)

comment:3 Changed 6 years ago by skyper

Ticket #9180 has been marked as a duplicate of this ticket.

comment:4 Changed 6 years ago by skyper

Cc: jphilipz added

comment:5 Changed 6 years ago by skyper

Keywords: keyboard added

comment:6 Changed 6 years ago by pbb

It works fine for me, on my Norwegian laptop keyboard (without numpad). The regular "+" zooms in, the regular "-" zooms out.

comment:7 in reply to:  6 Changed 6 years ago by skyper

Replying to pbb:

It works fine for me, on my Norwegian laptop keyboard (without numpad). The regular "+" zooms in, the regular "-" zooms out.

Please, girls and guys, we need a bit more information:

  • Please always add your system information (Help -> Show Status Report -> Report Bug (on bottom) and copy-paste the code block)
  • As this seems to be keyboard layout related, we also need your layout.

Thanks

comment:8 Changed 6 years ago by pbb

Ok, this is my status report:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-09-20 01:34:27
Last Changed Author: Don-vip
Revision: 6238
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-09-20 00:19:19 +0200 (Fri, 20 Sep 2013)
Last Changed Rev: 6238

Identification: JOSM/1.5 (6238 en) Windows 8 64-Bit
Memory Usage: 37 MB / 247 MB (5 MB allocated, but free)
Java version: 1.7.0_45, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Djava.util.Arrays.useLegacyMergeSort=true, -Djnlp.application.href=http://josm.openstreetmap.de/download/josm.jnlp, -Xbootclasspath/a:C:\Program Files (x86)\Java\jre7\lib\javaws.jar;C:\Program Files (x86)\Java\jre7\lib\deploy.jar;C:\Program Files (x86)\Java\jre7\lib\plugin.jar, -Djnlpx.vmargs=-Djava.util.Arrays.useLegacyMergeSort=true -Djnlp.application.href=http://josm.openstreetmap.de/download/josm.jnlp, -Djnlpx.jvm=<java.home>\bin\javaw.exe, -Djnlpx.splashport=51990, -Djnlpx.home=<java.home>\bin, -Djnlpx.remove=false, -Djnlpx.offline=false, -Djnlpx.relaunch=true, -Djnlpx.session.data=C:\Users\Peter\AppData\Local\Temp\session4026658896350249147, -Djnlpx.heapsize=NULL,NULL, -Djava.security.policy=file:C:\Program Files (x86)\Java\jre7\lib\security\javaws.policy, -DtrustProxy=true, -Xverify:remote, -Dsun.awt.warmup=true]

Plugin: PicLayer (29854)
Plugin: download_along (29854)
Plugin: imagery_offset_db (29832)
Plugin: measurement (29854)
Plugin: notes (v0.6)
Plugin: openstreetbugs (30004)

As said, my keyboard layout is Norwegian without numpad. On the Norwegian keyboard, "+" and "-" are accessible without need for shift. (Shift-"+" = "?" and Shift-"-" = "_".)

comment:9 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 6363/josm:

fix #7802 - Zoom in with "+" does not work

comment:10 Changed 6 years ago by jphilipz

Resolution: fixed
Status: closedreopened

Yes the '+' and '-' now seem to work fine in josm, but as stated in my 9180 ticket, the non-numberpad '+' and '-' dont work in the 'download from osm' dialog.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2013-12-02 02:34:25
Last Changed Author: Don-vip
Revision: 6432
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2013-12-02 00:54:07 +0100 (Mon, 02 Dec 2013)
Last Changed Rev: 6432

Identification: JOSM/1.5 (6432 en) Windows XP 32-Bit
Memory Usage: 79 MB / 247 MB (21 MB allocated, but free)
Java version: 1.7.0_40, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugin: undelete (29854)

comment:11 Changed 6 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 6438/josm:

fix #7802 - zoom with '+' and '-' in download dialog

comment:12 Changed 6 years ago by Don-vip

Ticket #9437 has been marked as a duplicate of this ticket.

comment:13 Changed 6 years ago by Don-vip

Milestone: 13.12 (6502)

comment:14 Changed 2 years ago by stoecker

Milestone: 13.12 (6502)13.12

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.