Modify

Opened 10 years ago

Closed 9 years ago

#7770 closed enhancement (duplicate)

Suggestion: Change cache structure

Reported by: AM909 Owned by: team
Priority: normal Milestone:
Component: Core imagery Version: tested
Keywords: slippy-map cache download Cc: AM909

Description

In r5181:

Under Windows, the cache for slippy-map in the download dialog is in "%USERPROFILE%\Local Settings\Temp\JMapViewerTiles_%USER%\imageryType". For a specific imageryType (like Bing Aerial Maps), all the tiles are stored in the one directory. This makes it very difficult to manage the directory manually when necessary. It's impossible to look at it with explorer, run any DOS commands on it, etc. Clearing it out with "RD /S "Bing Aerial Maps"" took more than a day on a reasonably fast machine!

I'd like to suggest breaking these directories into a tree structure, like zoom/x1/x2/y1/, where x2 is the least significant 2 digits of the x-coordinate and x1 are the upper significant digits. y1 is the y-coordinate without it's least significant 2 digits, resulting in 100 tiles per directory.

For example, if the file is named like x.y.png, 112987.543112.png becomes 1129/87/5431/12.png

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by Don-vip

Component: CoreCore imagery

comment:2 Changed 9 years ago by xeen

Resolution: duplicate
Status: newclosed

Closed as duplicate of #9813.
#9813 is about the same thing, but contains more details/info

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.