Modify

Opened 7 years ago

Closed 5 years ago

#7708 closed enhancement (fixed)

pre-formatting of bug reports

Reported by: malenki Owned by: team
Priority: minor Milestone: 14.08
Component: Core bugreport Version:
Keywords: Cc:

Description

The text JOSM provides in case of an error to paste to trac is nicely formatted at the window but isn't when it is simply copied to trac.

I'd suggest following formatting:

  • Instead of
    Revision: 5240
    

use

Revision: r5240
  • Use
     [[BR]]
    

(with a whitespace after links) at the end for linewraps

  • Wrap the error message itself in
    {{{
    }}}
    

Attachments (0)

Change History (9)

comment:1 Changed 7 years ago by simon04

When clicking the http://josm.openstreetmap.de/josmticket link in the dialog, the text displayed in the window is wrapped in a {{{/}}} for the corresponding ticket …

comment:2 Changed 7 years ago by skyper

Keywords: reportbug added

comment:3 Changed 7 years ago by skyper

Keywords: bug report added; reportbug removed

comment:4 Changed 6 years ago by Don-vip

Component: CoreCore bugreport
Keywords: bug report removed

comment:5 Changed 6 years ago by malenki

Priority: normalminor

comment:6 Changed 6 years ago by stoecker

Copy and Paste is usually only last method. All the others provide better formatted reports.

comment:7 Changed 5 years ago by Don-vip

Ticket #10174 has been marked as a duplicate of this ticket.

comment:8 Changed 5 years ago by Don-vip

Milestone: 14.08

comment:9 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7419/josm:

fix #7708 - pre-formatting of manual bug reports

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.