Modify

Opened 10 years ago

Closed 10 years ago

#7586 closed defect (fixed)

Wikipedia-Plugin under WindowsXP

Reported by: anonymous Owned by: simon04
Priority: major Milestone:
Component: Plugin wikipedia Version:
Keywords: language Cc:

Description (last modified by Don-vip)

Hello Simon,
it's not possible to download WP-POIs.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-04-08 01:32:19
Last Changed Author: simon04
Revision: 5173
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-04-08 01:27:30 +0200 (Sun, 08 Apr 2012)
Last Changed Rev: 5173

Identification: JOSM/1.5 (5173 de)
Memory Usage: 85 MB / 247 MB (32 MB allocated, but free)
Java version: 1.6.0_29, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows XP
Dataset consistency test: No problems found

Plugin: wikipedia (28187)

java.lang.RuntimeException: org.xml.sax.SAXParseException: Content is not allowed in prolog.
	at org.wikipedia.WikipediaToggleDialog$WikipediaDownloadAction.actionPerformed(WikipediaToggleDialog.java:176)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$000(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$2.run(Unknown Source)
	at java.awt.EventQueue$2.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: org.xml.sax.SAXParseException: Content is not allowed in prolog.
	at com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderImpl.parse(Unknown Source)
	at javax.xml.parsers.DocumentBuilder.parse(Unknown Source)
	at org.wikipedia.WikipediaToggleDialog$WikipediaDownloadAction.actionPerformed(WikipediaToggleDialog.java:155)
	... 37 more

Attachments (0)

Change History (5)

comment:1 Changed 10 years ago by anonymous

After changing the language from Preset "De:" to "de" it works fine.

Please support "wikipedia=lang:article" instead of "wikipedia:lang=article".

Thanks a lot.

comment:2 Changed 10 years ago by kolossos

Component: CorePlugin
Keywords: Wikipedia added

comment:3 Changed 10 years ago by Don-vip

Component: PluginPlugin wikipedia
Description: modified (diff)
Owner: changed from team to simon04

comment:4 in reply to:  1 Changed 10 years ago by skyper

Keywords: language added; Wikipedia removed
Priority: normalmajor

Replying to anonymous:

After changing the language from Preset "De:" to "de" it works fine.

Please support "wikipedia=lang:article" instead of "wikipedia:lang=article".

+1

Thought it does not work at all.

Changed priority as "wikipedia=lang:article" should be the default to support the intermedia links: https://wiki.openstreetmap.org/wiki/Wikipedia

comment:5 Changed 10 years ago by simon04

Resolution: fixed
Status: newclosed

Fixed in [o28244]/[o28245].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.