Modify

Opened 7 years ago

Closed 7 years ago

#7477 closed defect (fixed)

Error with plugin list

Reported by: skyper Owned by: team
Priority: critical Milestone:
Component: Core Version: latest
Keywords: plugin list Cc:

Description

  1. start josm and go to preference -> plugins
  2. click on "download list"

The list is downloaded but there are new plugins nor any update of already known ones ( I have the debian josm-plugin package installed e.g. I already have some plugins in the list even with empty preference dir).

On the console I get following exception

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-03-05 02:33:10
Last Changed Author: simon04
Revision: 5041
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-03-04 22:45:08 +0100 (Sun, 04 Mar 2012)
Last Changed Rev: 5041

Info: Missing preference file '$HOME/.josm/preferences.xml'. Creating a default preference file.
GET http://api.openstreetmap.org/api/capabilities... OK
Failed to parse plug-in list document from site 'http://josm.openstreetmap.de/plugin%<?plugins=>'. Skipping site. Exception was: org.openstreetmap.josm.plugins.PluginListParseException: java.io.IOException: Illegal entry in plugin list.
org.openstreetmap.josm.plugins.PluginListParseException: java.io.IOException: Illegal entry in plugin list.
	at org.openstreetmap.josm.plugins.PluginListParser.parse(PluginListParser.java:118)
	at org.openstreetmap.josm.plugins.ReadRemotePluginInformationTask.parsePluginListDocument(ReadRemotePluginInformationTask.java:317)
	at org.openstreetmap.josm.plugins.ReadRemotePluginInformationTask.realRun(ReadRemotePluginInformationTask.java:363)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:82)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:145)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:679)
Caused by: java.io.IOException: Illegal entry in plugin list.
	at org.openstreetmap.josm.plugins.PluginListParser.parse(PluginListParser.java:99)
	... 10 more

Identification: JOSM/1.5 (5041 en_GB)
Memory Usage: 80 MB / 592 MB (33 MB allocated, but free)
Java version: 1.6.0_24, Sun Microsystems Inc., OpenJDK 64-Bit Server VM
Operating system: Linux

Debian wheezy (testing)

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by Don-vip

In http://josm.openstreetmap.de/plugin :

canvec_helper.jar;http://svn.openstreetmap.org/applications/editors/josm/dist/canvec_helper.jar
	Manifest-Version: 1.0
	Ant-Version: Apache Ant 1.8.1
	Created-By: 1.6.0_20-b20 (Sun Microsystems Inc.)
	Author: Michael Bishop
	Plugin-Class: org.openstreetmap.josm.plugins.canvec_helper.canvec_helper
	Plugin-Date: 2012-02-27T04:13:26.469895Z
	Plugin-Description: Overlays the canvec tile grid on the map and prints URL's to the .zip files    future goals: allow auto-downloading and loading of canvec .osm files
	Plugin-Mainversion: 4394
	Plugin-Version: 27950
	de_Plugin-Description: Überlagert das canvec-Kachelraster auf der Karte und druckt URLs zu den .zip-Dateien\r
Zukünftige Ziele: Automatisches Herunterladen und Laden von canvec-.osm-Dateien ermöglichen
	it_Plugin-Description: Sovrappone la griglia dei tasselli canvec alla mappa e scrive gli indirizzi URL sui file .zip    obiettivi futuri: permettere lo scaricamento automatico ed il caricamento dei file .osm di canvec
	uk_Plugin-Description: Накладання сітки CanVec на мапу з упаковкою посиланнь у файл .zip для можливості автоматичного завантаження .osm файлів CanVec

The line "Zukünftige Ziele: Automatisches Herunterladen und Laden von canvec-.osm-Dateien ermöglichen" is wrong. Where does it come from ? Launchpad ?

comment:2 in reply to:  1 Changed 7 years ago by skyper

Replying to Don-vip:

The line "Zukünftige Ziele: Automatisches Herunterladen und Laden von canvec-.osm-Dateien ermöglichen" is wrong. Where does it come from ? Launchpad ?

As far as I know these descriptions are part of the plugin manifest. (Plugins)

There seems to be a typo in the german description. ("\r" after .zip-Dateinen).

Have a look at De:Plugins. The second part is missing.

comment:3 Changed 7 years ago by stoecker

Resolution: fixed
Status: newclosed

In 5047/josm:

fix #7477, i18n update

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.