Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7461 closed defect (duplicate)

Uploading changeset produces "unexpected exception"

Reported by: tongro Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Upload a particular changeset

What is the expected result? The changeset should be uploaded

What happens instead? An "unexpected exception" message appears

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-01-30 02:32:23
Last Changed Author: stoecker
Revision: 4878
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-01-30 00:02:54 +0100 (Mon, 30 Jan 2012)
Last Changed Rev: 4878

Identification: JOSM/1.5 (4878 en_GB)
Memory Usage: 38 MB / 1016 MB (6 MB allocated, but free)
Java version: 1.6.0_18, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux

Dataset consistency test:
[WARN - ZERO NODES] Way {Way id=114477704 version=3 MVT nodes=[]} has zero nodes


Plugin: DirectUpload (27355)
Plugin: undelete (27243)

java.lang.IndexOutOfBoundsException: Index:0 Size:0
	at org.openstreetmap.josm.tools.CopyList.rangeCheck(CopyList.java:132)
	at org.openstreetmap.josm.tools.CopyList.get(CopyList.java:59)
	at org.openstreetmap.josm.data.validation.tests.MultipolygonTest.visit(MultipolygonTest.java:120)
	at org.openstreetmap.josm.data.osm.Way.visit(Way.java:187)
	at org.openstreetmap.josm.data.validation.Test.visit(Test.java:139)
	at org.openstreetmap.josm.actions.upload.ValidateUploadHook.checkUpload(ValidateUploadHook.java:60)
	at org.openstreetmap.josm.actions.UploadAction.checkPreUploadConditions(UploadAction.java:137)
	at org.openstreetmap.josm.actions.UploadAction.uploadData(UploadAction.java:160)
	at org.openstreetmap.josm.actions.UploadAction.actionPerformed(UploadAction.java:203)
	at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1664)
	at javax.swing.JComponent.processKeyBinding(JComponent.java:2851)
	at javax.swing.KeyboardManager.fireBinding(KeyboardManager.java:285)
	at javax.swing.KeyboardManager.fireKeyboardAction(KeyboardManager.java:247)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(JComponent.java:2928)
	at javax.swing.JComponent.processKeyBindings(JComponent.java:2920)
	at javax.swing.JComponent.processKeyEvent(JComponent.java:2814)
	at java.awt.Component.processEvent(Component.java:5913)
	at java.awt.Container.processEvent(Container.java:2105)
	at java.awt.Component.dispatchEventImpl(Component.java:4497)
	at java.awt.Container.dispatchEventImpl(Container.java:2163)
	at java.awt.Component.dispatchEvent(Component.java:4323)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1881)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:749)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1025)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:892)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:713)
	at java.awt.Component.dispatchEventImpl(Component.java:4367)
	at java.awt.Container.dispatchEventImpl(Container.java:2163)
	at java.awt.Window.dispatchEventImpl(Window.java:2478)
	at java.awt.Component.dispatchEvent(Component.java:4323)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:649)
	at java.awt.EventQueue.access$000(EventQueue.java:96)
	at java.awt.EventQueue$1.run(EventQueue.java:608)
	at java.awt.EventQueue$1.run(EventQueue.java:606)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:116)
	at java.awt.EventQueue$2.run(EventQueue.java:622)
	at java.awt.EventQueue$2.run(EventQueue.java:620)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:619)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:138

Attachments (1)

charco.osm (633.3 KB) - added by tongro 10 years ago.
The file that is causing the problem

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by tongro

Attachment: charco.osm added

The file that is causing the problem

comment:1 Changed 10 years ago by tongro

Resolution: fixed
Status: newclosed

It was a way with no nodes that was causing the problem. I manually edited the file, and now it has uploaded successfully.

comment:2 Changed 10 years ago by skyper

Resolution: fixed
Status: closedreopened

comment:3 Changed 10 years ago by skyper

Resolution: duplicate
Status: reopenedclosed
Version: tested

comment:4 Changed 10 years ago by anonymous

Closed as duplicate of #7437.

comment:5 Changed 10 years ago by skyper

@ tongro

Do you still know what you did before this exception ? How did you get a way with zero nodes ?

If you do, please report it on ticket #7437.
Thanks

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.