Modify

Opened 8 years ago

Closed 8 years ago

#7437 closed defect (fixed)

IndexOutOfBounds when validating 0-nodes way

Reported by: Zverikk Owned by: team
Priority: major Milestone:
Component: Core Version: tested
Keywords: Cc:

Description

This exception prevents uploading changes.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-01-30 02:32:23
Last Changed Author: stoecker
Revision: 4878
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-01-30 00:02:54 +0100 (Mon, 30 Jan 2012)
Last Changed Rev: 4878

Identification: JOSM/1.5 (4878 ru)
Memory Usage: 51 MB / 247 MB (13 MB allocated, but free)
Java version: 1.6.0_18, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows XP

Dataset consistency test:
[WARN - ZERO NODES] Way {Way id=********* version=3 MVT nodes=[]} has zero nodes

Plugin: PicLayer (27676)

java.lang.IndexOutOfBoundsException: Index:0 Size:0
at org.openstreetmap.josm.tools.CopyList.rangeCheck(CopyList.java:132)
at org.openstreetmap.josm.tools.CopyList.get(CopyList.java:59)
at org.openstreetmap.josm.data.validation.tests.MultipolygonTest.visit(MultipolygonTest.java:120)
at org.openstreetmap.josm.data.osm.Way.visit(Way.java:187)
at org.openstreetmap.josm.data.validation.Test.visit(Test.java:139)
at org.openstreetmap.josm.actions.ValidateAction$ValidationTask.realRun(ValidateAction.java:169)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:82)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:137)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (6)

comment:1 Changed 8 years ago by akks

In 5012/josm:

tried to fix 0-node way validation bug, see #7437

Please close if fixed.

Last edited 8 years ago by akks (previous) (diff)

comment:2 in reply to:  description ; Changed 8 years ago by skyper

Replying to Zverikk:

Dataset consistency test:
[WARN - ZERO NODES] Way {Way id=********* version=3 MVT nodes=[]} has zero nodes

How did you get to this state (way with zero nodes) ?

This should not be possible !

Replying to akks:

In 5012/josm:

tried to fix 0-node way validation bug, see #7437

Please close if fixed.

Is this nota problem of validator in general as this way does not exist anymore (already deleted) but validator has it still in its list. I have seen similar issue with all three kinds of objects reported in #6640 but the exception is different and no data inconsistency.

comment:3 in reply to:  2 Changed 8 years ago by Zverikk

Replying to skyper:

Replying to Zverikk:

Dataset consistency test:
[WARN - ZERO NODES] Way {Way id=********* version=3 MVT nodes=[]} has zero nodes

How did you get to this state (way with zero nodes) ?

This should not be possible !

It wasn't me, but I suppose there were conflicts, and some nodes were deleted when resolving those.

comment:4 Changed 8 years ago by skyper

See also #7443

comment:5 Changed 8 years ago by anonymous

Ticket #7461 has been marked as a duplicate of this ticket.

comment:6 Changed 8 years ago by simon04

Resolution: fixed
Status: newclosed

IMHO this bug is fixed, but the search for the source for consistency data is ongoing.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.