Modify

Opened 8 years ago

Closed 8 years ago

Last modified 2 years ago

#7450 closed enhancement (fixed)

Warning against misaligned imagery

Reported by: DJTerentjev@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: imagery, offset Cc:

Description

Very often newbie to OSM start their contribution with moving old or create new objects according imagery. They just don't know imagery can be offset. Especially for mountainous areas imagery offset can be great. We need to inform them for first time they using imagery. Simple dialogue window. Please see attached image.

Attachments (8)

JOSM Eng.png (27.8 KB) - added by DJTerentjev@… 8 years ago.
Offset warning
Idea.png (181.5 KB) - added by akks 8 years ago.
black_x.png (155 bytes) - added by Zverikk 8 years ago.
josm-nagging.patch (981 bytes) - added by Zverikk 8 years ago.
AlignImageryPanel.java (4.2 KB) - added by Zverikk 8 years ago.
josm-nagging2.patch (4.7 KB) - added by akks 8 years ago.
TopPanelsAndImageryNagging.patch (8.1 KB) - added by akks 8 years ago.
screenshot_7450.png (175.8 KB) - added by skyper 8 years ago.
screenshot

Download all attachments as: .zip

Change History (51)

Changed 8 years ago by DJTerentjev@…

Attachment: JOSM Eng.png added

Offset warning

comment:1 Changed 8 years ago by skyper

Owner: changed from Dmitry <DJTerentjev@…> to team

comment:2 Changed 8 years ago by akks

This can be really useful for beginners. Adding is is also simple.

Maybe some picture in dialog can help (not absolutely necessary)
Is the link for "read more" already known?

comment:3 Changed 8 years ago by stoecker

I don't see a big sense in this. This is stated in many places already. When people don't read, one more text wont help as well and it will only annoy the others.

comment:4 Changed 8 years ago by akks

The sense is not big, but it exists. Maybe we need to show them some picture if they can not read?
Too many novices start from moving existing roads to "True Bing" :)

comment:5 Changed 8 years ago by Don-vip

If added, it should at least not be displayed in expert mode :)

comment:6 Changed 8 years ago by akks

Of course. And it has checkbox "not show this again" :)

Let us wait for pictures or links to place on this dialog.

comment:7 Changed 8 years ago by Dmitry <DJTerentjev@…>

So far I can find only wiki page in Russian http://wiki.openstreetmap.org/wiki/RU:Использование_аэрофотоснимков.
It have couple pictures. But let me translate it in English and I will look for better picture.

comment:8 Changed 8 years ago by akks

We need some small picture for users (maybe some crossing "before" and "after" shift with icon of shifting tool) and international link in wiki.

comment:9 Changed 8 years ago by mekillot@…

It's a very big problem that newibies align objects to bing, which has offset.
This fix will help at least to minimize this problem.

comment:11 Changed 8 years ago by Dmitry <DJTerentjev@…>

comment:12 in reply to:  11 Changed 8 years ago by akks

Replying to Dmitry:

This is international link: http://wiki.openstreetmap.org/wiki/Using_Imagery

Thank you!

Should we place some picture on dialog?
Something like following, but with better composition, idea and design:

and with much smaller filesize...

Last edited 8 years ago by akks (previous) (diff)

Changed 8 years ago by akks

Attachment: Idea.png added

comment:13 Changed 8 years ago by Dmitry <DJTerentjev@…>

akks,

For me any design will be OK. I'll happy with your design. Yesterday there was idea in irc: https://www2.dropbox.com/sh/p0ryog4igdaivdg/6XTjy-BL5s/Josm.png. I don't want upload this picture, because I could't reach its author FelisPimeja.

comment:14 in reply to:  13 Changed 8 years ago by akks

Replying to Dmitry:

akks,

For me any design will be OK. I'll happy with your design. Yesterday there was idea in irc: https://www2.dropbox.com/sh/p0ryog4igdaivdg/6XTjy-BL5s/Josm.png. I don't want upload this picture, because I could't reach its author FelisPimeja.

FelisPimeja's design can be good, but we have no such panel components currently, so for now let us do simple dialog :) If we want to include the warning in Tested, we

  • should hurry :)
  • should ask permission
  • should find some smaller descriptive picture or leave only text with link
Last edited 8 years ago by akks (previous) (diff)

comment:15 Changed 8 years ago by Dmitry <DJTerentjev@…>

Whose permission we should ask? I make one version of screenshots: http://wiki.openstreetmap.org/wiki/JOSM_offset_images and post it on the forum. Hopefully we will have some good ideas.

comment:16 in reply to:  15 Changed 8 years ago by akks

Replying to Dmitry:

Whose permission we should ask? I make one version of screenshots: http://wiki.openstreetmap.org/wiki/JOSM_offset_images and post it on the forum. Hopefully we will have some good ideas.

Permission from team to commit during stabilization phase when it will be ready. It would be polite :)

@team: How much size we can take for picture (50kb?, 20kb?). Or it is OK to include external web image in this case?

Last edited 8 years ago by akks (previous) (diff)

comment:17 Changed 8 years ago by stoecker

  • This is nothing for next tested, to late for this.
    • We have imagery there for years now, so one more month wont change situation significantly
  • An image wastes too much space
  • Why not simply (if it must be which I still not see) add a dialog linking to a description in online help?

comment:18 Changed 8 years ago by Zverikk

Please check http://textual.ru/josm-nagging.jar
I've attached a patch, a new class and a black X image (it looks better with it).

Note that the message appears only once after an imagery layer has been added, and only in non-expert mode.

Last edited 8 years ago by Zverikk (previous) (diff)

Changed 8 years ago by Zverikk

Attachment: black_x.png added

Changed 8 years ago by Zverikk

Attachment: josm-nagging.patch added

Changed 8 years ago by Zverikk

Attachment: AlignImageryPanel.java added

comment:19 Changed 8 years ago by Dmitry <DJTerentjev@…>

Looks good. Thanks.

comment:20 Changed 8 years ago by akks

Now when stable version is released we can add this too. There are two things to improve:

  • Duplicate UrlLabel - Zveriks's simplfied variant based on JLabel looks better then standard UrlLabel based on JEditorPane. Was there any reason to use JEditorPane? I tried to do simplification in main core UrlLabel. It works but font size and vertical alignment differs (size can be increased).
  • Adding panel (or mutliple panels?) on top on the map should probably be in MapFrame class. It can be useful for optional exposing additional MapMode settings, different messages, etc. What do you think?

comment:21 Changed 8 years ago by akks

In 5050/josm:

UrlLabel class simplification by Zverik, better label layout in VersionInfoPanel (see #7450, #7326)

comment:22 Changed 8 years ago by akks

I have included UrlLabel simplification, now the patch is shorter (works exactly like before).

Changed 8 years ago by akks

Attachment: josm-nagging2.patch added

comment:23 Changed 8 years ago by akks

5053/josm fixes code style of 5050/josm (removed import .*). 3 plugins are also fixed to use new UrlLabel correctly.

Last edited 8 years ago by akks (previous) (diff)

Changed 8 years ago by akks

comment:24 Changed 8 years ago by akks

MapFrame (Main.map) methods for adding, removing and getting components on top of MapView were introduced in this patch.
These components (usually panels but I also tried JButton's) can be useful for interface simplification or enhancements, I think.

Zveriks's patch was changed a little to use these methods instead of "hack" (now Main.map.addTopPanel(p)) :-)

Last edited 8 years ago by akks (previous) (diff)

comment:25 Changed 8 years ago by akks

A there more problems that needed to be solved before committing?

comment:26 Changed 8 years ago by akks

In 5091/josm:

Warning against misaligned imagery for new users - see #7450.
Added addTopPanel function in MapFrame for other possible enhancements

comment:27 Changed 8 years ago by akks

Please check the code and behaviour and close the ticket if all is OK.

comment:28 in reply to:  27 Changed 8 years ago by skyper

Replying to akks:

Please check the code and behaviour and close the ticket if all is OK.

On a 1280x1024 screen resolution the close button (X) is hidden by the toggle dialogs.

comment:29 Changed 8 years ago by akks

In 5119/josm:

minor fix: Imagery offset warning on small resolution screens, see #7450

comment:30 Changed 8 years ago by akks

Did last change help?

comment:31 in reply to:  30 Changed 8 years ago by skyper

Replying to akks:

Did last change help?

Yes it did, thanks.

comment:32 Changed 8 years ago by akks

It was easy :)
Can we close the ticket now?

comment:33 in reply to:  32 Changed 8 years ago by skyper

Replying to akks:

It was easy :)
Can we close the ticket now?

Seems to me that even applying did not help testing (probably many tester use expert mode and/or start with existing preferences).

Go ahead and close, I can reopen anytime if needed.

comment:34 Changed 8 years ago by akks

So let's close this for now :)

comment:35 Changed 8 years ago by akks

Resolution: fixed
Status: newclosed

comment:36 Changed 8 years ago by skyper

Resolution: fixed
Status: closedreopened

Sorry, probably did not check good enough.

I still have one minor issue:

The link to the help page turns invisible after few second. It is still there (between message and close button) and it works if you click on its spot but it is invisible.

Last edited 8 years ago by skyper (previous) (diff)

comment:37 Changed 8 years ago by akks

Can not reproduce... Which OS and screen resolution are you using?

comment:38 in reply to:  37 ; Changed 8 years ago by skyper

Replying to akks:

Can not reproduce... Which OS and screen resolution are you using?

GNU Debian wheezy (testing) with a 1024x768 resolution.

comment:39 in reply to:  38 ; Changed 8 years ago by akks

Replying to skyper:

Replying to akks:

Can not reproduce... Which OS and screen resolution are you using?

GNU Debian wheezy (testing) with a 1024x768 resolution.

Can not catch the effect on RedHat 4... Can you please check if UrlLabels in AboutDialog and History dialog (links to user and changeset) vanish the same way?

comment:40 in reply to:  39 Changed 8 years ago by skyper

Replying to akks:

Replying to skyper:

GNU Debian wheezy (testing) with a 1024x768 resolution.

Can not catch the effect on RedHat 4... Can you please check if UrlLabels in AboutDialog and History dialog (links to user and changeset) vanish the same way?

No not the same. With "About" it is hard to tell as I can not smaller the window, but with "History" it is definitly different. Have a look:

screenshot

This is on a different pc than yesterday ! Gonna try it with ubuntu later.

Changed 8 years ago by skyper

Attachment: screenshot_7450.png added

screenshot

comment:41 Changed 8 years ago by skyper

Stange if I smaller the main window it reappears in two lines and does not vanish anymore. A side affect is then that the toggle dialog right panels automatically smallers to only a small line.

It also seems to vanish faster on a faster machine.

comment:42 Changed 8 years ago by akks

Too big font for Josm interface - on Windows it is smaller and all fits even for 800x600 :)
I'll try to change layout a little.

comment:43 Changed 8 years ago by akks

Resolution: fixed
Status: reopenedclosed

In 5128/josm:

fix #7450: minor change - better layout tuning for small screens for imagery align nagging panel

comment:44 Changed 2 years ago by Don-vip

Ticket #6229 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.