Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7402 closed defect (fixed)

New plugin incompatibility

Reported by: pierre.quenee@… Owned by: team
Priority: normal Milestone:
Component: Plugin utilsplugin2 Version: latest
Keywords: Cc:

Description

Till 4949, uploading data fail with two plugin loaded: Uploading with plugin "print" only is OK. Uploading with plugin "utilsplugin2" only is OK. Between the uploading crash.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-02-17 02:32:15
Last Changed Author: stoecker
Revision: 4961
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-02-16 21:21:17 +0100 (Thu, 16 Feb 2012)
Last Changed Rev: 4961

Identification: JOSM/1.5 (4961 fr)
Memory Usage: 177 MB / 1820 MB (27 MB allocated, but free)
Java version: 1.6.0_21, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7

Plugin: print (27676)
Plugin: utilsplugin2 (27761)

java.lang.reflect.InvocationTargetException

at java.awt.EventQueue.invokeAndWait(Unknown Source)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:87)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:145)
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Caused by: java.lang.IllegalArgumentException: Action must have shortcut set

at org.openstreetmap.josm.tools.MultikeyActionsHandler.addAction(MultikeyActionsHandler.java:204)
at org.openstreetmap.josm.gui.layer.JumpToMarkerActions.initialize(JumpToMarkerActions.java:27)
at org.openstreetmap.josm.gui.dialogs.LayerListDialog.createInstance(LayerListDialog.java:94)
at org.openstreetmap.josm.gui.MapFrame.<init>(MapFrame.java:191)
at org.openstreetmap.josm.Main.addLayer(Main.java:322)
at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.finish(DownloadOsmTask.java:177)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$1.run(PleaseWaitRunnable.java:89)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.Dialog$1.run(Unknown Source)
at java.awt.Dialog$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Unknown Source)
at java.awt.Component.show(Unknown Source)
at java.awt.Component.setVisible(Unknown Source)
at java.awt.Window.setVisible(Unknown Source)
at java.awt.Dialog.setVisible(Unknown Source)
at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$4.run(PleaseWaitProgressMonitor.java:170)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (7)

comment:1 in reply to:  description Changed 8 years ago by pierre.quenee@…

Sorry for bad english ...

Till 4949, downloading data fail with two plugin loaded: downloading with plugin "print" only is OK. downloading with plugin "utilsplugin2" only is OK. Between the download crash.

comment:2 Changed 8 years ago by stoecker

We're in the process of fixing shortcut conflicts. So this conflict will vanish.

Anyway the exception is wrong and must be fixed. The multikey functionality must be possible to be disabled when no shortcut is set: It is possible to remove shortcuts in the settings and this must not result in an exception.

comment:3 Changed 8 years ago by stoecker

Ticket #7408 has been marked as a duplicate of this ticket.

comment:4 Changed 8 years ago by stoecker

Resolution: fixed
Status: newclosed

In 4999/josm:

fix #7402 - multikey shortcut handling

comment:5 Changed 8 years ago by stoecker

Ticket #7158 has been marked as a duplicate of this ticket.

comment:6 Changed 8 years ago by stoecker

Ticket #7440 has been marked as a duplicate of this ticket.

comment:7 Changed 8 years ago by rickmastfan67

Ticket #7439 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.