Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7393 closed enhancement (duplicate)

unable to close dialog when offline - presets

Reported by: Luebeck Owned by: Luebeck
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description (last modified by skyper)

if i work offline and a start the properties dialog for object-templates the programm try to download definitions by the web (dialog with the processbar to http://josm.openstreetmap.de/presets). click to the cancel buttons will not close the dialog.only a click on the red abort-buttone (top-right) will close the dialog with the message.

then the message

Fehler beim Laden der Objektvorlagenliste von 'http://josm.openstreetmap.de/presets'. Details: java.net.UnknownHostException: josm.openstreetmap.de

comes.

Attachments (0)

Change History (4)

comment:1 Changed 9 years ago by skyper

Description: modified (diff)
Summary: unable to close dialog when offline - presentsunable to close dialog when offline - presets

Please, tell us what presets you use, your system info (first three paragraphs Help -> Show status report) and add the whole exceptions details and not just the first line.

Thanks


Can not reproduce with "NewTags" and "steps" presets. Both messages close after clicking "OK".

Using /usr/lib/jvm/java-6-openjdk/bin/java to execute josm.
Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-02-15 02:32:11
Last Changed Author: xeen
Revision: 4934
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-02-15 02:44:53 +0100 (Wed, 15 Feb 2012)
Last Changed Rev: 4934

Warning: failed to read MOTD from 'http://josm.openstreetmap.de/wiki/StartupPage'. Exception was: java.net.UnknownHostException: josm.openstreetmap.de
java.net.UnknownHostException: osmtools.de
	at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:175)
	at java.net.Socket.connect(Socket.java:546)
	at sun.net.NetworkClient.doConnect(NetworkClient.java:169)
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:409)
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:530)
	at sun.net.www.http.HttpClient.<init>(HttpClient.java:240)
	at sun.net.www.http.HttpClient.New(HttpClient.java:321)
	at sun.net.www.http.HttpClient.New(HttpClient.java:338)
	at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:935)
	at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:876)
	at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:801)
	at org.openstreetmap.josm.io.MirroredInputStream.connectFollowingRedirect(MirroredInputStream.java:275)
	at org.openstreetmap.josm.io.MirroredInputStream.checkLocal(MirroredInputStream.java:220)
	at org.openstreetmap.josm.io.MirroredInputStream.<init>(MirroredInputStream.java:79)
	at org.openstreetmap.josm.io.MirroredInputStream.<init>(MirroredInputStream.java:40)
	at org.openstreetmap.josm.gui.tagging.TaggingPreset.readAll(TaggingPreset.java:1187)
	at org.openstreetmap.josm.gui.tagging.TaggingPreset.readAll(TaggingPreset.java:1214)
	at org.openstreetmap.josm.gui.tagging.TaggingPreset.readFromPreferences(TaggingPreset.java:1250)
	at org.openstreetmap.josm.gui.preferences.TaggingPresetPreference.initialize(TaggingPresetPreference.java:260)
	at org.openstreetmap.josm.Main.<init>(Main.java:279)
	at org.openstreetmap.josm.gui.MainApplication.<init>(MainApplication.java:64)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:253)
java.net.UnknownHostException: josm.openstreetmap.de
	at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:175)
	at java.net.Socket.connect(Socket.java:546)
	at sun.net.NetworkClient.doConnect(NetworkClient.java:169)
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:409)
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:530)
	at sun.net.www.http.HttpClient.<init>(HttpClient.java:240)
	at sun.net.www.http.HttpClient.New(HttpClient.java:321)
	at sun.net.www.http.HttpClient.New(HttpClient.java:338)
	at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:935)
	at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:876)
	at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:801)
	at org.openstreetmap.josm.io.MirroredInputStream.connectFollowingRedirect(MirroredInputStream.java:275)
	at org.openstreetmap.josm.io.MirroredInputStream.checkLocal(MirroredInputStream.java:220)
	at org.openstreetmap.josm.io.MirroredInputStream.<init>(MirroredInputStream.java:79)
	at org.openstreetmap.josm.io.MirroredInputStream.<init>(MirroredInputStream.java:40)
	at org.openstreetmap.josm.gui.tagging.TaggingPreset.readAll(TaggingPreset.java:1187)
	at org.openstreetmap.josm.gui.tagging.TaggingPreset.readAll(TaggingPreset.java:1214)
	at org.openstreetmap.josm.gui.tagging.TaggingPreset.readFromPreferences(TaggingPreset.java:1250)
	at org.openstreetmap.josm.gui.preferences.TaggingPresetPreference.initialize(TaggingPresetPreference.java:260)
	at org.openstreetmap.josm.Main.<init>(Main.java:279)
	at org.openstreetmap.josm.gui.MainApplication.<init>(MainApplication.java:64)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:253)
loading plugin 'turnlanes' (version 27676)
loading plugin 'reverter' (version 27676)
RemoteControl: adding command "revert_changeset" (handled by RevertChangesetHandler)
loading plugin 'utilsplugin2' (version 27710)

Last edited 9 years ago by skyper (previous) (diff)

comment:2 Changed 9 years ago by skyper

Owner: changed from team to Luebeck
Status: newneedinfo

comment:3 Changed 9 years ago by simon04

Resolution: duplicate
Status: needinfoclosed

comment:4 Changed 9 years ago by simon04

Closed as duplicate of #5369.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Luebeck.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.