Modify

Opened 8 years ago

Closed 7 years ago

#7385 closed defect (fixed)

Relation History not shown correctly when comparing changesets

Reported by: rickmastfan67 Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: Cc:

Description (last modified by rickmastfan67)

The history in relations isn't shown correctly compared to nodes and ways. For instance, on a way, the history correctly tells me which node was deleted or added and what place in the way that happened. With relations, it isn't doing the same way. Everything shows up in "red" after an item in the relation has been added/moved/deleted, making it look like every item in the relation was deleted in both compared changesets, which isn't the case.

I have no idea when or if it ever worked correctly for relations, or if this is even a regression because of #6652 (changeset [4566]) or not.


Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-02-12 02:32:10
Last Changed Author: simon04
Revision: 4918
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-02-11 18:56:53 +0100 (Sat, 11 Feb 2012)
Last Changed Rev: 4918

Identification: JOSM/1.5 (4918 en)
Memory Usage: 205 MB / 2730 MB (71 MB allocated, but free)
Java version: 1.6.0_30, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: OpeningHoursEditor (27676)
Plugin: buildings_tools (27676)
Plugin: imageryadjust (27744)
Plugin: licensechange (27676)
Plugin: mapdust (27596)
Plugin: measurement (27464)
Plugin: openstreetbugs (27355)
Plugin: reverter (27676)
Plugin: turnrestrictions (27676)
Plugin: undelete (27649)
Plugin: utilsplugin2 (27710)

Attachments (1)

relation_history_problem.png (80.8 KB) - added by rickmastfan67 8 years ago.

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by rickmastfan67

comment:1 Changed 8 years ago by rickmastfan67

Description: modified (diff)

comment:2 Changed 7 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 5292/josm:

fix #7385 - Relation History not shown correctly when comparing changesets

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.