Modify

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#736 closed defect (fixed)

OSM layer no longer transparent

Reported by: sahoff@… Owned by: framm
Priority: major Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

The changes from changeset r631 make the OSM layer hide all other layers.

Changing line 179 in src/org/openstreetmap/josm/gui/layer/OsmDataLayer.java from

BufferedImage bim = new BufferedImage(mv.getWidth(), mv.getHeight(), Transparency.OPAQUE);

to

BufferedImage bim = new BufferedImage(mv.getWidth(), mv.getHeight(), Transparency.TRANSLUCENT);

fixes the problem for me.

Attachments (0)

Change History (3)

comment:1 Changed 14 years ago by dnaber

I had attached a fixed version (josm-render-speedup.2.diff) to http://josm.openstreetmap.de/ticket/685, but it seems the first version was committed. The new version renders everything to a BufferedImage, not only the OSM layer.

comment:2 Changed 14 years ago by anonymous

Resolution: fixed
Status: newclosed

comment:3 Changed 14 years ago by dnaber

The problem is not yet fixed because my change (rendering to BufferedImage) in OsmDataLayer now needs to be reverted (i.e. my second patch was a replacement for the first one, it was not an addition).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.