Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7312 closed defect (fixed)

IllegalArgumentException inversing a filter

Reported by: skyper Owned by: filter exception
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. entered filter:
    type=way & highway=* -lanes=*
    
  2. inversed filter

What is the expected result?

filtered data

What happens instead?

Exception

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2012-01-24 02:32:20
Last Changed Author: bastiK
Revision: 4863
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2012-01-24 00:40:20 +0100 (Tue, 24 Jan 2012)
Last Changed Rev: 4863

Identification: JOSM/1.5 (4863 de)
Memory Usage: 68 MB / 248 MB (11 MB allocated, but free)
Java version: 1.6.0_18, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: reverter (27604)
Plugin: turnlanes (27355)
Plugin: utilsplugin2 (27564)

java.lang.IllegalArgumentException: Width (-1) and height (-1) cannot be <= 0
	at java.awt.image.DirectColorModel.createCompatibleWritableRaster(DirectColorModel.java:1016)
	at java.awt.image.BufferedImage.<init>(BufferedImage.java:338)
	at org.openstreetmap.josm.tools.ImageProvider.createRotatedImage(ImageProvider.java:789)
	at org.openstreetmap.josm.data.osm.visitor.paint.MapPainter.drawRestriction(MapPainter.java:903)
	at org.openstreetmap.josm.data.osm.visitor.paint.MapPainter.drawRestriction(MapPainter.java:1087)
	at org.openstreetmap.josm.gui.mappaint.NodeElemStyle.paintPrimitive(NodeElemStyle.java:307)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer$StyleCollector.drawAll(StyledMapRenderer.java:140)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer.render(StyledMapRenderer.java:233)
	at org.openstreetmap.josm.gui.layer.OsmDataLayer.paint(OsmDataLayer.java:264)
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:455)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:509)
	at javax.swing.JComponent.paintChildren(JComponent.java:866)
	at javax.swing.JSplitPane.paintChildren(JSplitPane.java:1046)
	at javax.swing.JComponent.paint(JComponent.java:1038)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5138)
	at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:302)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1145)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5086)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4896)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:740)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:696)
	at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:676)
	at javax.swing.RepaintManager.access$700(RepaintManager.java:57)
	at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1550)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:647)
	at java.awt.EventQueue.access$000(EventQueue.java:96)
	at java.awt.EventQueue$1.run(EventQueue.java:608)
	at java.awt.EventQueue$1.run(EventQueue.java:606)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:617)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

I have the new search enabled. #7230

Only happened on first use of filter and I can not reproduce it, so far. Will save the osm file.

Attachments (1)

filter_bug_7312.osm.gz (70.9 KB) - added by skyper 9 years ago.
example file

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by bastiK

Caused by [4822]. (Image is not completely loaded when createRotatedImage is called.)

comment:2 in reply to:  1 ; Changed 9 years ago by skyper

Replying to bastiK:

Caused by [4822]. (Image is not completely loaded when createRotatedImage is called.)

It happened again. this time when editing tags which changed the object into filtered one.

I can provide osm data file, way ids and filter string if needed.

Last edited 9 years ago by skyper (previous) (diff)

comment:3 Changed 9 years ago by bastiK

Resolution: fixed
Status: newclosed

In [4870/josm]:

fixed #7312 - Image not completely loaded when rotating image

comment:4 in reply to:  2 ; Changed 9 years ago by bastiK

Replying to skyper:

I can provide osm data file, way ids and filter string if needed.

Yes, please, I'd like to see this.

comment:5 in reply to:  4 Changed 9 years ago by skyper

Replying to bastiK:

Replying to skyper:

I can provide osm data file, way ids and filter string if needed.

Yes, please, I'd like to see this.

Sorry, probably won't get to this machine till monday and did not take the files with me.

Changed 9 years ago by skyper

Attachment: filter_bug_7312.osm.gz added

example file

comment:6 Changed 9 years ago by skyper

I did not get the same exception but a similar when adding filter:

type=way & highway=* -lanes=*

and reversing the search.

Selecting some of the ways with high focus and then moving the map, produced the same exception as already listed.

Selecting some ways and adding

lines=1

does not produce any exception as it did last week.

All tests with r4863

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain filter exception.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.