Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7243 closed enhancement (worksforme)

Consistent zoom levels

Reported by: LM_1 Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: zoom Cc:

Description

Currently it seems that any arbitrary number can become a zoom level (meaning the 'xx m' information next to the scale in upper left corner). Still nor with wheel nor by moving it directly with mouse can all numbers be set - there is some minimum step.

This breaks the caching of wms tiles, since these depend on zoom level. Every time there is a different zoom, and it is not possible to set it to a specific number. If it was, one could start wms services always at the same zoom level to get consistent data and maybe use data from cache while offline.

I would appreciate if
it was possible to set zoom to specific level
OR
zoom would always be chosen from the same set
OR
any other way to reuse zoom level from last time

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by jttt

You can save wms layer at specific zoom (Set WMS bookmark on wms layer) - it will ensure that cache is always used. Then you can choose this bookmarked wms source and use Zoom to native resolution (in wms layer popup menu) to get exactly the zoom that is already cached (to prevent distortion caused by resizing tiles). If you're using slow wms service, you might also find Precache imagery tiles along this track (in gpx layer popup menu) useful.

comment:2 Changed 10 years ago by stoecker

Resolution: worksforme
Status: newclosed

comment:3 Changed 10 years ago by LM_1

Thanks.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.