Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7205 closed defect (duplicate)

unerwarteter Fehler beim Löschen eines bereits gelöschten Objektes

Reported by: palinka@… Owned by: team
Priority: minor Milestone:
Component: Core Version:
Keywords: Cc:

Description

Bei den Prüfergebnissen hatte ich zwei verschiedene Warnungen für das selbe Objekt. Ich habe bei der ersten Warnung auf das Objekt geklickt und es gelöscht. Nach dem Löschen blieben im Fenster beide Warnungen bestehen. Danch habe ich auf die 2. Warnung geklickt und wollte das Objekt auswählen und löschen. Dann kam der unerwartete Fehler. Also beim Löschen eines Objektes, dass nicht mehr da war.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-12-16 02:32:17
Last Changed Author: Don-vip
Revision: 4666
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-12-15 21:12:57 +0100 (Thu, 15 Dec 2011)
Last Changed Rev: 4666

Identification: JOSM/1.5 (4666 de)
Memory Usage: 108 MB / 494 MB (5 MB allocated, but free)
Java version: 1.6.0_26, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: FixAddresses (27178)
Plugin: RoadSigns (27241)
Plugin: buildings_tools (27119)
Plugin: mapdust (27119)
Plugin: openstreetbugs (27119)
Plugin: turnrestrictions (27241)

java.lang.IllegalArgumentException: {Way id=-323 version=0 MVDT nodes=[]} is already deleted

at org.openstreetmap.josm.command.DeleteCommand.executeCommand(DeleteCommand.java:112)
at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:53)
at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:36)
at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:58)
at org.openstreetmap.josm.actions.mapmode.DeleteAction.doActionPerformed(DeleteAction.java:149)
at org.openstreetmap.josm.actions.DeleteAction.actionPerformed(DeleteAction.java:28)
at javax.swing.SwingUtilities.notifyAction(Unknown Source)
at javax.swing.JComponent.processKeyBinding(Unknown Source)
at javax.swing.KeyboardManager.fireBinding(Unknown Source)
at javax.swing.KeyboardManager.fireKeyboardAction(Unknown Source)
at javax.swing.JComponent.processKeyBindingsForAllComponents(Unknown Source)
at javax.swing.JComponent.processKeyBindings(Unknown Source)
at javax.swing.JComponent.processKeyEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$000(Unknown Source)
at java.awt.EventQueue$1.run(Unknown Source)
at java.awt.EventQueue$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue$2.run(Unknown Source)
at java.awt.EventQueue$2.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by skyper

Resolution: duplicate
Status: newclosed

comment:2 Changed 10 years ago by skyper

Closed as duplicate of #5566.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.