Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7197 closed defect (fixed)

Regression: plugin verification broken

Reported by: iav Owned by: Larry0ua
Priority: critical Milestone:
Component: Core Version: tested
Keywords: Cc:

Description

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-12-19 02:32:42
Last Changed Author: Don-vip
Revision: 4667
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-12-19 00:02:30 +0100 (Mon, 19 Dec 2011)
Last Changed Rev: 4667

Identification: JOSM/1.5 (4667 ru)
Memory Usage: 24 MB / 247 MB (7 MB allocated, but free)
Java version: 1.6.0_26, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows XP

Plugin: DirectDownload (27119)
Plugin: FastDraw (27178)
Plugin: FixAddresses (27323)
Plugin: OpeningHoursEditor (27178)
Plugin: PicLayer (27296)
Plugin: RoadSigns (27241)
Plugin: buildings_tools (27119)
Plugin: colorscheme (26762)
Plugin: contourmerge (1003)
Plugin: dataimport (26731)
Plugin: download_along (27119)
Plugin: gpxfilter (27178)
Plugin: multipoly-convert (27019)
Plugin: namemanager (26731)
Plugin: openstreetbugs (27119)
Plugin: reltoolbox (27241)
Plugin: restart (26731)
Plugin: reverter (27159)
Plugin: tag2link (27304)
Plugin: tageditor (27178)
Plugin: tagging-preset-tester (27178)
Plugin: terracer (27119)
Plugin: turnrestrictions (27241)
Plugin: undelete (27243)
Plugin: utilsplugin2 (27289)
Plugin: waydownloader (27241)
Plugin: wayselector (27019)

org.openstreetmap.josm.plugins.PluginException: В модуле PicLayer произошла ошибка

at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:32)
at org.openstreetmap.josm.plugins.PluginHandler.notifyMapFrameChanged(PluginHandler.java:833)
at org.openstreetmap.josm.Main.setMapFrame(Main.java:208)
at org.openstreetmap.josm.Main.addLayer(Main.java:279)
at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.finish(DownloadOsmTask.java:176)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$1.run(PleaseWaitRunnable.java:86)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$000(Unknown Source)
at java.awt.EventQueue$1.run(Unknown Source)
at java.awt.EventQueue$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.Dialog$1.run(Unknown Source)
at java.awt.Dialog$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Unknown Source)
at java.awt.Component.show(Unknown Source)
at java.awt.Component.setVisible(Unknown Source)
at java.awt.Window.setVisible(Unknown Source)
at java.awt.Dialog.setVisible(Unknown Source)
at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$3.run(PleaseWaitProgressMonitor.java:83)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$000(Unknown Source)
at java.awt.EventQueue$1.run(Unknown Source)
at java.awt.EventQueue$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Caused by: java.lang.reflect.InvocationTargetException

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:29)
... 39 more

Caused by: java.lang.NoSuchMethodError: org.openstreetmap.josm.gui.IconToggleButton.setAutoHideDisabledButton(Z)V

at org.openstreetmap.josm.plugins.piclayer.PicLayerPlugin.picLayerActionButtonFactory(PicLayerPlugin.java:125)
at org.openstreetmap.josm.plugins.piclayer.PicLayerPlugin.mapFrameInitialized(PicLayerPlugin.java:108)
... 44 more

Attachments (0)

Change History (5)

comment:1 Changed 8 years ago by Larry0ua

Looks like you're using latest PicLayer which has:

Plugin-Mainversion: 4669

So the question is how you got it installed on JOSM version 4667? Looks like you've ran latest JOSM, installed 'latest' PicLayer and then ran 'tested' JOSM.

I think that is some JOSM-related trouble - it does not check plugin mainversion before starting it, only before installing.

If you think so - reassign issue to Core.

comment:2 Changed 8 years ago by iav

Resolution: invalid
Status: newclosed

comment:3 in reply to:  1 Changed 8 years ago by stoecker

Component: Plugin piclayerCore
Priority: normalcritical
Resolution: invalid
Status: closedreopened
Summary: josm crash on startRegression: plugin verification broken

Core's plugin loading verification is completely broken. Instead of checking the real loaded plugin file some artificial data from the server is checked. Error exists since Gubaers plugin rework which joined all the plugin data into one single structure.

comment:4 Changed 8 years ago by stoecker

Resolution: fixed
Status: reopenedclosed

In [4737/josm]:

fix #7197 - fix plugin version check on load

comment:5 Changed 8 years ago by stoecker

Ticket #7241 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Larry0ua.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.