Modify

Opened 8 years ago

Closed 8 years ago

#7172 closed defect (fixed)

CT isn't always loaded by the History window when looking at an items history

Reported by: rickmastfan67 Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Steps to reproduce:

  1. Make sure first that the "Author" window is completely closed (if it's open, close the Author window [not minimize] and restart JOSM before going to Step #2)
  2. Download the following way in JOSM: 11826390
  3. Select the way you just downloaded and open up the "History" window on the right hand side of your screen.
  4. Click the "Show" button to load the history of the way.

Expected results:
The people who have accepted the CT should have the green checkmark showing that they have.

What happens:
Everybody is shown as "Undecided" except the people that have "Auto-accepted".

=====

There is a workaround that can be used to not have this happen. You need to leave the "Author" window open on the right minimized at all times. Then the "History" window will load the CT properly.

Now, the reason I marked this as "major" is because some people want to have as few windows opened on the right as possible to do what they want to do, so some people (like me) would have the "Author" window totally deactivated on the right and not just minimized.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-12-21 02:32:07
Last Changed Author: Don-vip
Revision: 4673
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-12-20 23:18:17 +0100 (Tue, 20 Dec 2011)
Last Changed Rev: 4673

Identification: JOSM/1.5 (4673 en)
Memory Usage: 147 MB / 2730 MB (80 MB allocated, but free)
Java version: 1.6.0_29, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: OpeningHoursEditor (27178)
Plugin: buildings_tools (27119)
Plugin: imageryadjust (27178)
Plugin: licensechange (27241)
Plugin: mapdust (27119)
Plugin: measurement (26731)
Plugin: openstreetbugs (27119)
Plugin: restart (26731)
Plugin: reverter (27159)
Plugin: turnlanes (26731)
Plugin: turnrestrictions (27241)
Plugin: undelete (27243)
Plugin: utilsplugin2 (27241)

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by simon04

Resolution: fixed
Status: newclosed

In [4674/josm]:

fix #7172 - CT isn't always loaded by the History window when looking at an items history

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.