Modify

Opened 10 years ago

Closed 10 years ago

#7119 closed defect (fixed)

Crass on start, tested and latest version, ubuntu 11.10

Reported by: avila.gas@… Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: Cc:

Description (last modified by Don-vip)

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-10-31 02:32:25
Last Changed Author: stoecker
Revision: 4550
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-10-30 22:19:50 +0100 (Sun, 30 Oct 2011)
Last Changed Rev: 4550

Identification: JOSM/1.5 (4550 en)
Memory Usage: 32 MB / 481 MB (14 MB allocated, but free)
Java version: 1.6.0_23, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux

Plugin: reltoolbox
Plugin: restart

java.lang.RuntimeException: org.xml.sax.SAXParseException; lineNumber: 6; columnNumber: 3; The element type "hr" must be terminated by the matching end-tag "</hr>".
	at org.openstreetmap.josm.tools.XmlObjectParser.start(XmlObjectParser.java:296)
	at org.openstreetmap.josm.tools.XmlObjectParser.startWithValidation(XmlObjectParser.java:316)
	at org.openstreetmap.josm.gui.mappaint.xml.XmlStyleSource.loadStyleSource(XmlStyleSource.java:70)
	at org.openstreetmap.josm.gui.mappaint.MapPaintStyles.readFromPreferences(MapPaintStyles.java:157)
	at org.openstreetmap.josm.gui.preferences.MapPaintPreference.initialize(MapPaintPreference.java:160)
	at org.openstreetmap.josm.Main.<init>(Main.java:251)
	at org.openstreetmap.josm.gui.MainApplication.<init>(MainApplication.java:60)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:241)
Caused by: org.xml.sax.SAXParseException; lineNumber: 6; columnNumber: 3; The element type "hr" must be terminated by the matching end-tag "</hr>".
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1234)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:525)
	at org.openstreetmap.josm.tools.XmlObjectParser.start(XmlObjectParser.java:294)
	... 7 more

Attachments (0)

Change History (9)

comment:1 Changed 10 years ago by Don-vip

Description: modified (diff)

comment:2 Changed 10 years ago by akks

It seems like custom paint style file is not available on server... I had the same problem.

comment:3 in reply to:  2 Changed 10 years ago by avila.gas@…

Replying to akks:

It seems like custom paint style file is not available on server... I had the same problem.

How did you fix it?

comment:4 Changed 10 years ago by stoecker

Priority: blockernormal

comment:5 Changed 10 years ago by skyper

Owner: changed from GAston to avila.gas@…
Status: newneedinfo

comment:6 Changed 10 years ago by skyper

Owner: changed from avila.gas@… to akks

comment:7 Changed 10 years ago by akks

I just turned off broken-link style, so it is not much help. Core should show some warnings and disable the style, I think.

comment:8 Changed 10 years ago by akks

Owner: changed from akks to team
Status: needinfonew

comment:9 Changed 10 years ago by simon04

Resolution: fixed
Status: newclosed

In r5032, adding an XML error to elemstyles.xml does not show an error upon start, but logs the following on stderr and disables the style.

[Fatal Error] :139:2: Element type "a" must be followed by either attribute specifications, ">" or "/>".
Warning: failed to parse Mappaint styles from 'resource://styles/standard/elemstyles.xml'. Error was: [139:2] Element type "a" must be followed by either attribute specifications, ">" or "/>".
org.xml.sax.SAXParseException; lineNumber: 139; columnNumber: 2; Element type "a" must be followed by either attribute specifications, ">" or "/>".
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1236)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:568)
	at org.openstreetmap.josm.tools.XmlObjectParser.start(XmlObjectParser.java:274)
	at org.openstreetmap.josm.tools.XmlObjectParser.startWithValidation(XmlObjectParser.java:301)
	at org.openstreetmap.josm.gui.mappaint.xml.XmlStyleSource.loadStyleSource(XmlStyleSource.java:71)
	at org.openstreetmap.josm.gui.mappaint.MapPaintStyles.readFromPreferences(MapPaintStyles.java:166)
	at org.openstreetmap.josm.gui.preferences.map.MapPaintPreference.initialize(MapPaintPreference.java:177)
	at org.openstreetmap.josm.Main.<init>(Main.java:284)
	at org.openstreetmap.josm.gui.MainApplication.<init>(MainApplication.java:64)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:253)

Apparently fixed in r4726.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.