Modify

Opened 8 years ago

Closed 4 years ago

#6963 closed enhancement (fixed)

display warnings in a less intrusive way than popups

Reported by: flaimo Owned by: team
Priority: major Milestone:
Component: Core Version: tested
Keywords: popup Cc: thomie, avarab@…, mjulius

Description

as a poweruser i tend to work rather quickly with keyboard-shortcuts and a graphic tablet. whenever i miss selecting a certain node with my pen, but then press a command shortly afterwards, i get a popup windows with a warning that a certain action can't be applied. this gets rather annoying after a certain time, since you know what the message says it says anyway, but you have to move the mouse/pen or hit the enter key to make it go away.

i would rather like to see warnings be displayed in an unintrusive overlay, which doesn't have to be clicked away manually, bud rather fades away automatically after 1 or 2 seconds.

real popup messages should only be used for real errors or where a certain user interaction is needed.

Attachments (1)

mockup.jpg (2.0 MB) - added by flaimo 8 years ago.
i added a mockup screen of what i had in mind (kind of like the filter overlay)

Download all attachments as: .zip

Change History (14)

Changed 8 years ago by flaimo

Attachment: mockup.jpg added

i added a mockup screen of what i had in mind (kind of like the filter overlay)

comment:1 Changed 8 years ago by olejorgenb

Agreed. If someone want to work on this they should check out FilterDialog.drawOSDText (activate some filter to see how it looks)

comment:2 Changed 8 years ago by simon04

Ticket #4553 has been marked as a duplicate of this ticket.

comment:3 in reply to:  description Changed 8 years ago by skyper

Replying to flaimo:

i would rather like to see warnings be displayed in an unintrusive overlay, which doesn't have to be clicked away manually, bud rather fades away automatically after 1 or 2 seconds.

You are talking about info messages and no warnings.

real popup messages should only be used for real errors or where a certain user interaction is needed.

+1

comment:4 Changed 8 years ago by skyper

Cc: thomie avarab@… mjulius added
Keywords: popup added

from duplicate #4553: mjulius:

A transitional message window that looks pretty much like a tooltip and shows up near the top or bottom of the screen would be perfect for these kind of warnings. It should have a little bigger font, come up without getting input focus, be transparent to mouse clicks, and disappear after, say, 5 sec.

Those messages that you have to click on or hit enter to make them go away can be annoying.

comment:5 Changed 6 years ago by bastiK

In 6124/josm:

see #6963 - new unintrusive notification messages

comment:6 Changed 6 years ago by bastiK

In 6130/josm:

see #6963 - converted popups to notifications for all actions in the Tools menu (TODO: Simplify Way)

comment:7 Changed 6 years ago by bastiK

In 6131/josm:

see #6963 - optional help button for notifications; use notifications in Simplify Way action

comment:8 Changed 6 years ago by bastiK

In 6132/josm:

see #6963 - new message after successful upload; use notification for NMEA import

comment:9 Changed 6 years ago by Don-vip

Are there still warnings to fix or can we close this ticket ?

comment:10 Changed 6 years ago by flaimo

  • With the latest stable build (6238) i still get a popup warning when selecting two ways and pressing alt+x on mac os x. "The selected Was is not a split way…"
  • Also when selecting one node and then selecting the "Symmetry" menu entry from the more tools menu, a popup warning shows up.

Also the maintainers of the most important plugins should be informed, so that they utilize the new feature for their warnings if possible.

comment:11 Changed 5 years ago by Don-vip

Ticket #6617 has been marked as a duplicate of this ticket.

comment:12 Changed 4 years ago by simon04

In 8808/josm:

see #6963 - ParallelWayAction: use notification for invalid selection message

comment:13 in reply to:  10 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

Replying to flaimo:

  • With the latest stable build (6238) i still get a popup warning when selecting two ways and pressing alt+x on mac os x. "The selected Was is not a split way…"

Has been addressed in [o30177].

  • Also when selecting one node and then selecting the "Symmetry" menu entry from the more tools menu, a popup warning shows up.

Addressed in r8808.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.