Modify

Opened 15 years ago

Closed 15 years ago

#692 closed defect (duplicate)

error loading osm data with slippy map

Reported by: teesee Owned by: framm
Priority: major Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Version:
609 (2008-04-17 03:14:08)
Java Version 1.60_03
BS: Kubuntu 7.10

steps:
Datei/vom OSM Server herunterladen/Slippy map
min area selected
OpenStreetMap Daten ->selected
Rohe GPS Daten -> selected
als neue Ebene laden -> selected

after loading this error occured:

Path: josm
URL: http://www.openstreetmap.de/svn/josm
Repository Root: http://www.openstreetmap.de/svn/josm
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 609
Node Kind: directory
Last Changed Author: framm
Last Changed Rev: 609
Last Changed Date: 2008-04-17 03:14:08 +0200 (Thu, 17 Apr 2008)

java.lang.RuntimeException: java.lang.reflect.InvocationTargetException

at org.openstreetmap.josm.gui.PleaseWaitRunnable.closeDialog(PleaseWaitRunnable.java:146)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:95)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
at java.lang.Thread.run(Thread.java:619)

Caused by: java.lang.reflect.InvocationTargetException

at java.awt.EventQueue.invokeAndWait(EventQueue.java:997)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.closeDialog(PleaseWaitRunnable.java:142)
... 4 more

Caused by: java.lang.NoClassDefFoundError: Could not initialize class org.openstreetmap.josm.plugins.validator.Severity

at org.openstreetmap.josm.plugins.validator.ErrorLayer.getToolTipText(ErrorLayer.java:92)
at org.openstreetmap.josm.gui.dialogs.LayerListDialog$1.getListCellRendererComponent(LayerListDialog.java:160)
at javax.swing.plaf.basic.BasicListUI.updateLayoutState(BasicListUI.java:1342)
at javax.swing.plaf.basic.BasicListUI.maybeUpdateLayoutState(BasicListUI.java:1292)
at javax.swing.plaf.basic.BasicListUI$Handler.valueChanged(BasicListUI.java:2605)
at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:167)
at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:147)
at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:194)
at javax.swing.DefaultListSelectionModel.insertIndexInterval(DefaultListSelectionModel.java:615)
at javax.swing.plaf.basic.BasicListUI$Handler.intervalAdded(BasicListUI.java:2563)
at javax.swing.AbstractListModel.fireIntervalAdded(AbstractListModel.java:130)
at javax.swing.DefaultListModel.add(DefaultListModel.java:462)
at org.openstreetmap.josm.gui.dialogs.LayerListDialog.layerAdded(LayerListDialog.java:291)
at org.openstreetmap.josm.gui.MapView.addLayer(MapView.java:151)
at org.openstreetmap.josm.Main.addLayer(Main.java:298)
at org.openstreetmap.josm.actions.downloadtasks.DownloadGpsTask$Task.finish(DownloadGpsTask.java:46)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$4.run(PleaseWaitRunnable.java:128)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:199)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:177)
at java.awt.Dialog$1.run(Dialog.java:1039)
at java.awt.Dialog$3.run(Dialog.java:1091)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Dialog.java:1089)
at java.awt.Component.show(Component.java:1419)
at java.awt.Component.setVisible(Component.java:1372)
at java.awt.Window.setVisible(Window.java:801)
at java.awt.Dialog.setVisible(Dialog.java:979)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$3.run(PleaseWaitRunnable.java:78)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:177)
at java.awt.Dialog$1.run(Dialog.java:1039)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:177)
at java.awt.Dialog$1.run(Dialog.java:1039)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)

Attachments (0)

Change History (2)

comment:1 Changed 15 years ago by anonymous

Version: latest

comment:2 Changed 15 years ago by framm

Resolution: duplicate
Status: newclosed

duplicate of #693, #694; fixed in r610.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.