Modify

Opened 15 years ago

Closed 15 years ago

Last modified 14 years ago

#694 closed defect (fixed)

Validator Exception, when OSM files came from server

Reported by: fatbozz Owned by: framm
Priority: critical Milestone:
Component: Core Version: latest
Keywords: validator Cc: fatbozz

Description

Steps to reproduce
Open JOSM
Validator plugin is on ( v7395)
Download OSM
Select bookmark ( ive download: http://www.openstreetmap.org/api/0.5/map?bbox=14.430898430887606,50.206880837889,14.589151
721772417,50.312442362365125 )

Then Exception throws:


Path: josm
URL: http://www.openstreetmap.de/svn/josm
Repository Root: http://www.openstreetmap.de/svn/josm
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 609
Node Kind: directory
Last Changed Author: framm
Last Changed Rev: 609
Last Changed Date: 2008-04-17 03:14:08 +0200 (Thu, 17 Apr 2008)


java.lang.RuntimeException: java.lang.reflect.InvocationTargetException
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.closeDialog(PleaseWaitRunnable.java:146)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:95)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.reflect.InvocationTargetException
	at java.awt.EventQueue.invokeAndWait(Unknown Source)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.closeDialog(PleaseWaitRunnable.java:142)
	... 4 more
Caused by: org.openstreetmap.josm.plugins.PluginException: An error occoured in plugin validator
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:33)
	at org.openstreetmap.josm.Main.setMapFrame(Main.java:152)
	at org.openstreetmap.josm.Main.addLayer(Main.java:293)
	at org.openstreetmap.josm.actions.NewAction.actionPerformed(NewAction.java:21)
	at org.openstreetmap.josm.Main.editLayer(Main.java:305)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$Task.finish(DownloadOsmTask.java:49)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable$4.run(PleaseWaitRunnable.java:128)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.Dialog$1.run(Unknown Source)
	at java.awt.Dialog$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Unknown Source)
	at java.awt.Component.show(Unknown Source)
	at java.awt.Component.setVisible(Unknown Source)
	at java.awt.Window.setVisible(Unknown Source)
	at java.awt.Dialog.setVisible(Unknown Source)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable$3.run(PleaseWaitRunnable.java:78)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:30)
	... 28 more
Caused by: java.lang.NoSuchMethodError: org.openstreetmap.josm.data.osm.visitor.SimplePaintVisitor.getPreferencesColor(Ljava/lang/String;Ljava/awt/Color;)Ljava/awt/Color;
	at org.openstreetmap.josm.plugins.validator.Severity.<clinit>(Severity.java:10)
	at org.openstreetmap.josm.plugins.validator.ErrorLayer.getToolTipText(ErrorLayer.java:92)
	at org.openstreetmap.josm.gui.dialogs.LayerListDialog$1.getListCellRendererComponent(LayerListDialog.java:160)
	at javax.swing.plaf.basic.BasicListUI.updateLayoutState(Unknown Source)
	at javax.swing.plaf.basic.BasicListUI.maybeUpdateLayoutState(Unknown Source)
	at javax.swing.plaf.basic.BasicListUI$Handler.valueChanged(Unknown Source)
	at javax.swing.DefaultListSelectionModel.fireValueChanged(Unknown Source)
	at javax.swing.DefaultListSelectionModel.fireValueChanged(Unknown Source)
	at javax.swing.DefaultListSelectionModel.fireValueChanged(Unknown Source)
	at javax.swing.DefaultListSelectionModel.changeSelection(Unknown Source)
	at javax.swing.DefaultListSelectionModel.changeSelection(Unknown Source)
	at javax.swing.DefaultListSelectionModel.setSelectionInterval(Unknown Source)
	at javax.swing.JList.setSelectedIndex(Unknown Source)
	at javax.swing.JList.setSelectedValue(Unknown Source)
	at org.openstreetmap.josm.gui.dialogs.LayerListDialog.activeLayerChange(LayerListDialog.java:311)
	at org.openstreetmap.josm.gui.MapView.setActiveLayer(MapView.java:316)
	at org.openstreetmap.josm.gui.MapView.addLayer(MapView.java:154)
	at org.openstreetmap.josm.Main.addLayer(Main.java:298)
	at org.openstreetmap.josm.plugins.validator.OSMValidatorPlugin.mapFrameInitialized(OSMValidatorPlugin.java:83)
	... 33 more

Then i click report bug and copy to trac. Now i want disable plugin then i click 2times on disable but messagebox.png is result. Now another exception

Path: josm
URL: http://www.openstreetmap.de/svn/josm
Repository Root: http://www.openstreetmap.de/svn/josm
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 609
Node Kind: directory
Last Changed Author: framm
Last Changed Rev: 609
Last Changed Date: 2008-04-17 03:14:08 +0200 (Thu, 17 Apr 2008)


java.lang.NoClassDefFoundError: Could not initialize class org.openstreetmap.josm.plugins.validator.Severity
	at org.openstreetmap.josm.plugins.validator.ErrorLayer.getToolTipText(ErrorLayer.java:92)
	at org.openstreetmap.josm.gui.dialogs.LayerListDialog$1.getListCellRendererComponent(LayerListDialog.java:160)
	at javax.swing.plaf.basic.BasicListUI.updateLayoutState(Unknown Source)
	at javax.swing.plaf.basic.BasicListUI.maybeUpdateLayoutState(Unknown Source)
	at javax.swing.plaf.basic.BasicListUI.getPreferredSize(Unknown Source)
	at javax.swing.JComponent.getPreferredSize(Unknown Source)
	at javax.swing.ScrollPaneLayout.layoutContainer(Unknown Source)
	at java.awt.Container.layout(Unknown Source)
	at java.awt.Container.doLayout(Unknown Source)
	at java.awt.Container.validateTree(Unknown Source)
	at java.awt.Container.validateTree(Unknown Source)
	at java.awt.Container.validateTree(Unknown Source)
	at java.awt.Container.validateTree(Unknown Source)
	at java.awt.Container.validateTree(Unknown Source)
	at java.awt.Container.validateTree(Unknown Source)
	at java.awt.Container.validateTree(Unknown Source)
	at java.awt.Container.validateTree(Unknown Source)
	at java.awt.Container.validate(Unknown Source)
	at javax.swing.RepaintManager.validateInvalidComponents(Unknown Source)
	at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(Unknown Source)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (1)

messagebox.PNG (82.0 KB) - added by fatbozz 15 years ago.
Messagebox, when validator plugin isnt accepted

Download all attachments as: .zip

Change History (2)

Changed 15 years ago by fatbozz

Attachment: messagebox.PNG added

Messagebox, when validator plugin isnt accepted

comment:1 Changed 15 years ago by anonymous

Resolution: fixed
Status: newclosed

fixed in r610.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.