Modify

Opened 9 years ago

Closed 6 years ago

Last modified 6 years ago

#6909 closed enhancement (fixed)

Necessity of History toggle dialog?

Reported by: simon04 Owned by: team
Priority: normal Milestone: 14.11
Component: Core Version:
Keywords: History toggle dialog Cc: bastiK, stoecker

Description

As the history dialog can be accessed through the View menu (Help/Action/ObjectHistory), I don't see the necessity of the History toggle dialog any more. Is there any? Can this toggle dialog be removed? This would also help to achieve #6731.

Attachments (1)

6909.patch (1.3 KB) - added by simon04 8 years ago.

Download all attachments as: .zip

Change History (25)

comment:1 Changed 9 years ago by Don-vip

I don't see any either. And I don't like this dialog because of its redundancy with Selection dialog (the list content is the same). By the way, no existing plugin seem to reference it, so it could safely be removed.

comment:2 Changed 9 years ago by olejorgenb

+1

I've always wondered why this was a toggle dialog. It was really annoying to waste the space (or enable/disable it for each use) before I discovered other methods of bringing up the history (eg. ctrl+h).

comment:3 Changed 9 years ago by simon04

Cc: bastiK stoecker added

Before removing this dialog, I'd like to hear the opinion of the main developers. Does the removal cause any problems?

comment:4 Changed 9 years ago by stoecker

I'm against it. Maybe this is a case for the expert/beginner mode as well.

comment:5 in reply to:  4 Changed 9 years ago by simon04

Replying to stoecker:

I'm against it. Maybe this is a case for the expert/beginner mode as well.

why wouldn't you like to have the History td removed, i.e., which feature would be missing afterwards?

comment:6 Changed 9 years ago by bastiK

I guess there have been plans to extend this dialog; but there is no reason to believe this will happen any time soon.

At the moment, the history toggle dialog seems superfluous, maybe we can hide it with history.button_hidden=true?

There is still one problem with the menu item: When a lot of objects are selected (e.g. Ctrl+A), a plenty of windows will pop up. I never had this problem with the toggle window, because it provides a "sub-selection".

comment:7 in reply to:  6 Changed 9 years ago by simon04

Replying to bastiK:

At the moment, the history toggle dialog seems superfluous, maybe we can hide it with history.button_hidden=true?

That's fine by me.

There is still one problem with the menu item: When a lot of objects are selected (e.g. Ctrl+A), a plenty of windows will pop up. I never had this problem with the toggle window, because it provides a "sub-selection".

Personally, I never used that "sub-selection" as I found it just as easy to deselect the corresponding objects directly.

Changed 8 years ago by simon04

Attachment: 6909.patch added

comment:8 in reply to:  6 ; Changed 8 years ago by simon04

Summary: Necessity of History toggle dialog?[Patch] Necessity of History toggle dialog?

Replying to bastiK:

At the moment, the history toggle dialog seems superfluous, maybe we can hide it with history.button_hidden=true?

Patch attached which disables the dialog per default. It can be reactivated using the setting dialog.history.enabled.

comment:9 in reply to:  8 ; Changed 8 years ago by bastiK

Replying to simon04:

Replying to bastiK:

At the moment, the history toggle dialog seems superfluous, maybe we can hide it with history.button_hidden=true?

Patch attached which disables the dialog per default. It can be reactivated using the setting dialog.history.enabled.

Why not hide it "the normal way"? (Like from the right click menu of the button.)

comment:10 in reply to:  9 ; Changed 8 years ago by simon04

Replying to bastiK:

Why not hide it "the normal way"? (Like from the right click menu of the button.)

Good idea, but then the dialog is still selectable in the Windows menu.

comment:11 in reply to:  10 Changed 8 years ago by bastiK

Replying to simon04:

Replying to bastiK:

Why not hide it "the normal way"? (Like from the right click menu of the button.)

Good idea, but then the dialog is still selectable in the Windows menu.

Ok, haven't thought of that.

Maybe a new toggle button state: Keep it in the ">>" menu at the bottom left but only display it in the windows menu, when the button is visible on the left (i.e. history.button_hidden=false).

This new logic would apply to "expert" toggle buttons in non-expert mode and the history dialog in general.

The idea is, that it is already hidden enough in the ">>" menu, no need to hide it further.

comment:12 Changed 8 years ago by stoecker

The expert mode must not be 100%. We don't want to restrict users, we want to easy their usage experience. I don't see a problem, when the buttons are hidden in left menu, but not in windows menu.

When users start to wonder about this, it anyways gets time they check the expert button. :-)

comment:13 Changed 8 years ago by simon04

Summary: [Patch] Necessity of History toggle dialog?Necessity of History toggle dialog?

Do we want to take any action concerning the History toggle dialog?

comment:14 Changed 7 years ago by Don-vip

Ticket #7643 has been marked as a duplicate of this ticket.

comment:15 Changed 6 years ago by Don-vip

I'd like to get rid of the History dialog and move its "Show" button to the Selection dialog as a new "Show history" button. Is everyone OK with this solution?

comment:16 Changed 6 years ago by Don-vip

Milestone: 14.11

As nobody objected I'm going to do this :) All arguments in favour of the history toggle dialog are addressed with this solution as it allows "sub-selection" for history.

comment:17 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 7750/josm:

fix #6909 - remove history toggle dialog in favour of a new history button in selection toggle dialog

comment:18 Changed 6 years ago by SammysHP

Took some time to find the new button.

Currently a double click on an item in the list does nothing. It would be nice if this would open the history dialog as before.

comment:19 in reply to:  18 Changed 6 years ago by skyper

Resolution: fixed
Status: closedreopened

Replying to SammysHP:

Took some time to find the new button.

Currently a double click on an item in the list does nothing. It would be nice if this would open the history dialog as before.

Regression should be fixed before new release.

comment:20 in reply to:  18 ; Changed 6 years ago by bastiK

Resolution: wontfix
Status: reopenedclosed

Replying to SammysHP:

Currently a double click on an item in the list does nothing. It would be nice if this would open the history dialog as before.

No, this is not what I would expect from double click in selection dialog.

comment:21 Changed 6 years ago by Don-vip

Resolution: wontfixfixed

This ticket is fixed :)

comment:22 in reply to:  20 Changed 6 years ago by SammysHP

Replying to bastiK:

No, this is not what I would expect from double click in selection dialog.

So, what do you expect there? There are many complaints regarding the new UI. Switching from the history dialog to the selection dialog is no big deal. But if you are used to double click on an entry to open the browser, the current behavior is very annoying.

PS: IMHO it is a bad behavior to change the status in every comment. We should discuss it first, then decide what to do.

comment:23 Changed 6 years ago by stoecker

Users always complain about UI changes. Question is if this change is a major drawback for all users or only changes the workflow of a few users. I'm pretty sure the second is the case, as only few users actually look at the history of multiple objects.

PS: IMHO it is a bad behavior to change the status in every comment. We should discuss it first, then decide what to do.

We already did decide.

comment:24 in reply to:  23 Changed 6 years ago by SammysHP

Replying to stoecker:

as only few users actually look at the history of multiple objects.

Has anybody said something about multiple objects? I suggested to open the history browser for a double click on an entry in the selection dialog. Currently no (obvious) action is associated with a double click.¹

¹ Except for selecting only that single object which might be used by some users of course. Changing that might be a bad idea too. I stay with ctrl+h.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.