Modify

Opened 11 years ago

Closed 10 years ago

#656 closed defect (worksforme)

Java exception when trying to get user info

Reported by: juan_lucas_dr@… Owned by: framm
Priority: major Milestone:
Component: Plugin Version:
Keywords: usertools userinfo Cc:

Description

I tried to find out who had uploaded a way inside a national park in Spain (just curiosity). This is the link I copied to start download in JOSM:

http://www.openstreetmap.org/?lat=39.67473&lon=-0.48771&zoom=17&layers=0BFT

Then I select a random node and click the menu item: "User - Show Author Panel", then the error message shows:

====================================
Path: josm
URL: http://www.openstreetmap.de/svn/josm
Repository Root: http://www.openstreetmap.de/svn/josm
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 587
Node Kind: directory
Last Changed Author: framm
Last Changed Rev: 587
Last Changed Date: 2008-03-21 01:24:05 +0100 (Fri, 21 Mar 2008)

java.lang.ArrayIndexOutOfBoundsException: No such child: 100

at java.awt.Container.getComponent(Unknown Source)
at usertools.UserToolsPlugin$1.actionPerformed(UserToolsPlugin.java:102)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.AbstractButton.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

====================================

Interestingly, I was not able to see the author name in Osma level 17 (perhaps the green background confuses me.)

I use the last version of Usertools plugin.

Thanks for that great software!
Lucas

Attachments (0)

Change History (2)

comment:1 Changed 11 years ago by anonymous

This seems to be a issue with the plugin? Maybe you should try to contact Tim Waters. Have you tried the author info directly supplied by JOSM, instead of the userinfo plugin? Finding out the author should be possible with the author dialog. Close the properties dialog and press Alt-a to open it (or choose the icon with the two guys and the vertical scroll bar).

comment:2 Changed 10 years ago by Hasienda

Keywords: userinfo added
Resolution: worksforme
Status: newclosed
Version: latest

I used Usertools:author_dialog from userinfo plugin quit a lot with JOSM revision

  • 1073
  • 1075 (latest to date)

without problems. Can't reproduce the behavior while following exactly the initial problem description downloading and using data from the same Spanish area.

@reporter: test with latest revision, please re-open, if it's still a problem for you

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.