Modify

Opened 10 years ago

Closed 10 years ago

Last modified 5 years ago

#6481 closed defect (fixed)

Imagery default server list not stored (WAS: Background menu contents)

Reported by: anonymous Owned by: team
Priority: major Milestone:
Component: Core imagery Version: tested
Keywords: imagery list empty startup Cc:

Description (last modified by stoecker)

When starting JOSM the first time after installation, in the background menu there are several entries (OpenStreetMap Mapnik, Bing?, ...).
After the first restart, this menu is empty.
For me (as a beginner) this was very confusing.
Version: 4064

Attachments (0)

Change History (9)

comment:1 Changed 10 years ago by skyper

Component: unspecifiedCore imagery
Owner: changed from team to Upliner

comment:2 Changed 10 years ago by stoecker

Owner: changed from Upliner to anonymous
Status: newneedinfo

Can you reproduce this? The only way to get that menu empty is to remove all entries from it in configuration.

comment:3 in reply to:  2 Changed 10 years ago by skyper

Replying to stoecker:

Can you reproduce this? The only way to get that menu empty is to remove all entries from it in configuration.

Yes, I can !
Not, every time but quite often.

There seems to be some problem with downloading the available server list in prefs, too.

See also #6470

Last edited 10 years ago by skyper (previous) (diff)

comment:4 Changed 10 years ago by skyper

Ticket #6470 has been marked as a duplicate of this ticket.

comment:5 Changed 10 years ago by skyper

Keywords: imagery list empty startup added
Owner: changed from anonymous to team
Status: needinfonew

I do not have any problem with the avaiable server list. (Was on a different system + connection anyway).

I did not get any clue from wireshark. For what exactly should I look for ?

With r4153 and r4064 I noticed that with an empty preference dir it works,

  • but if you just close JOSM and restart it the list is empty and stays empty.
  • If you just open the preference dialog and click on OK on the first startup or open a imagery layer, everything works as expected.

Last working version is r4013 and r4018 does not work anymore.

Java version: 1.6.0_18, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux
Last edited 10 years ago by skyper (previous) (diff)

comment:6 Changed 10 years ago by skyper

Priority: normalmajor
Summary: Background menu contentsImagery default server list not stored (WAS: Background menu contents)

I still have this problem with r4417

comment:7 Changed 10 years ago by stoecker

Resolution: fixed
Status: newclosed

In [4428/josm]:

fix #6481 - default layers vanishing after first start

comment:8 Changed 5 years ago by severin.menard@…

Still have the problem with v9060 on a couple of Windows 8 computers with JRE8u60 from students I am teaching. I deleted the Preferences file and restarted JOSM wiht internet connection, remains the same. Reinstalling JOSM does not change it

comment:9 Changed 5 years ago by stoecker

Description: modified (diff)

Don't try to reactivate old closed tickets. Open a new ticket and supply the information requested for new tickets including a proper description of your problem.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.