Modify

Opened 10 years ago

Closed 10 years ago

#6463 closed defect (fixed)

NPE after downloading certain gps data

Reported by: Cobra Owned by: Cobra
Priority: major Milestone:
Component: Core Version: latest
Keywords: template_report Cc: malenki

Description

What steps will reproduce the problem?

  1. download data for this bbox with raw gps data: http://www.openstreetmap.org/?minlon=8.2273865&minlat=48.1935565&maxlon=8.2340813&maxlat=48.1987057&box=yes

What is the expected result?
osm and gps data getting downloaded and displayed.

What happens instead?
OSM data is displayed correctly.
While loading gps data josm crashes, the window elements aren't painted.
After clicking "Do nothing" you can delete the gpx layer and josm seems to work again.
If you zoom/pan, josm crashes again: "java.lang.NullPointerException", no more details.

Other areas seem to work fine as far as I tested.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-06-14 08:44:02
Last Changed Author: stoecker
Revision: 4136
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-06-13 14:08:38 +0200 (Mon, 13 Jun 2011)
Last Changed Rev: 4136

Identification: JOSM/1.5 (4136 en)
Memory Usage: 255 MB / 910 MB (78 MB allocated, but free)
Java version: 1.6.0_24, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Linux
Dataset consistency test: No problems found

Plugin: ImproveWayAccuracy (26025)
Plugin: PicLayer (25219)
Plugin: alignways (25199)
Plugin: contourmerge (25626)
Plugin: measurement (25199)
Plugin: openstreetbugs (25664)
Plugin: openvisible (25192)
Plugin: proj4j (25454)
Plugin: reltoolbox (26125)
Plugin: reverter (26093)
Plugin: terracer (26029)
Plugin: undelete (26073)
Plugin: utilsplugin2 (26051)

java.lang.NullPointerException
	at org.openstreetmap.josm.gui.layer.GpxLayer.paint(GpxLayer.java:471)
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:452)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:506)
	at javax.swing.JComponent.paintChildren(JComponent.java:862)
	at javax.swing.JSplitPane.paintChildren(JSplitPane.java:1030)
	at javax.swing.JComponent.paint(JComponent.java:1038)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5124)
	at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:278)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1224)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5072)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4882)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:785)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:713)
	at javax.swing.RepaintManager.seqPaintDirtyRegions(RepaintManager.java:693)
	at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(SystemEventQueueUtilities.java:125)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:642)
	at java.awt.EventQueue.access$000(EventQueue.java:85)
	at java.awt.EventQueue$1.run(EventQueue.java:603)
	at java.awt.EventQueue$1.run(EventQueue.java:601)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:612)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:12

Attachments (1)

6463.gpx (14.5 KB) - added by Cobra 10 years ago.
this file should crash josm

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by Cobra

r4125 is working fine, r4131 is broken.
I'll test more revisions later if nobody has a clue what's wrong here.

comment:2 Changed 10 years ago by Cobra

r4129 introduced this bug.

comment:3 Changed 10 years ago by stoecker

Sorry does not happen here. Can you save the GPS layer? Does it result in same error when loaded?

If not please specify the exact boundary to download.

Code says last should never be null when this is true!. Seems this is wrong, so there may be a bug which has been hidden previously :-)

comment:4 Changed 10 years ago by stoecker

Owner: changed from team to Cobra
Status: newneedinfo

comment:5 Changed 10 years ago by Cobra

Right-clicking the layer produces the same error.
I could save the layer only after hiding it.

Loading this file causes the same error.

I've tested this with r4136 (current latest) and r4137 (current SVN, built locally), no difference.

Changed 10 years ago by Cobra

Attachment: 6463.gpx added

this file should crash josm

comment:6 Changed 10 years ago by malenki

Cc: malenki added

Not confirm with neither the description in the OP nor the last appended file using Josm r4136 and r4137.

java version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)

comment:7 Changed 10 years ago by stoecker

Please attach your config file as well (strip username/password).

comment:8 Changed 10 years ago by Cobra

This setting triggers this bug:

draw.rawgps.lines.force=true

I renamed ~/.josm to start from scratch and tested with r4138.

comment:9 Changed 10 years ago by stoecker

Resolution: fixed
Status: needinfoclosed

In [4143/josm]:

fix #6463 - fix NPE, remove some of the new toolbar warnings for image menu

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Cobra.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.