Modify

Opened 10 years ago

Closed 10 years ago

#6462 closed defect (fixed)

Can't open previously saved *.osm files + can't upload any data in r4136

Reported by: rickmastfan67 Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Just updated to r4136 from r4135 and noticed that when I tried to open previously working *.osm files, that they wouldn't open at all. JOSM gave me the following text message: "Cannot open 1 file because no suitable file importer is available" (and the location of the file I tried to open below it). I then reverted back down to r4135 and those files opened again properly.

Also, I was doing some minor work in r4136 (before I found out about the opening of the files) and got an error message when I tried to upload the work I did to the OSM database. Here it is:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-06-14 01:31:24
Last Changed Author: stoecker
Revision: 4136
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-06-13 14:08:38 +0200 (Mon, 13 Jun 2011)
Last Changed Rev: 4136

Identification: JOSM/1.5 (4136 en)
Memory Usage: 156 MB / 3640 MB (51 MB allocated, but free)
Java version: 1.6.0_25, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: OpeningHoursEditor (26002)
Plugin: RoadSigns (25192)
Plugin: alignways (25199)
Plugin: buildings_tools (25905)
Plugin: download_along (25190)
Plugin: imageryadjust (25199)
Plugin: mapdust (25839)
Plugin: measurement (25199)
Plugin: michigan_left (25190)
Plugin: openstreetbugs (25664)
Plugin: restart (25199)
Plugin: reverter (26093)
Plugin: turnlanes (26117)
Plugin: turnrestrictions (26079)
Plugin: undelete (26073)
Plugin: utilsplugin2 (26051)

java.lang.NoClassDefFoundError: org/apache/commons/codec/binary/Base64
	at oauth.signpost.signature.OAuthMessageSigner.<init>(OAuthMessageSigner.java:37)
	at oauth.signpost.signature.HmacSha1MessageSigner.<init>(HmacSha1MessageSigner.java:30)
	at oauth.signpost.AbstractOAuthConsumer.<init>(AbstractOAuthConsumer.java:63)
	at oauth.signpost.basic.DefaultOAuthConsumer.<init>(DefaultOAuthConsumer.java:33)
	at org.openstreetmap.josm.data.oauth.OAuthParameters.buildConsumer(OAuthParameters.java:135)
	at org.openstreetmap.josm.io.OsmConnection.addOAuthAuthorizationHeader(OsmConnection.java:118)
	at org.openstreetmap.josm.io.OsmConnection.addAuth(OsmConnection.java:135)
	at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:551)
	at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:513)
	at org.openstreetmap.josm.io.OsmApi.openChangeset(OsmApi.java:351)
	at org.openstreetmap.josm.io.OsmServerWriter.uploadOsm(OsmServerWriter.java:192)
	at org.openstreetmap.josm.gui.io.UploadPrimitivesTask.realRun(UploadPrimitivesTask.java:237)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:83)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:129)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: org.apache.commons.codec.binary.Base64
	at java.net.URLClassLoader$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	... 17 more

It seems to me that r4136 didn't get built correctly. I noticed that it was about ~71KB smaller that r4135. (4135 - 6635KB; 4136 - 6564KB) So, you might want to get r4136 rebuilt right away, otherwise, several more reports might show up later.

Attachments (0)

Change History (1)

comment:1 Changed 10 years ago by stoecker

Resolution: fixed
Status: newclosed

Rebuilt file. should be fixed now.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.