Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#6432 closed defect (fixed)

WMS and TMS do not handle projection/projection changes correct

Reported by: stoecker Owned by: team
Priority: critical Milestone:
Component: Core Version:
Keywords: Cc:

Description

WMS does not handle projection changes.

TMS does not handle projection at all (it only supports EPSG:4326 and Mercator).

Suggestion:

  • add a SupportedProjections function to layer
    • For TMS fill in EPSG:4326 and Mercator
    • For WMS fill in the values supported by the server
      • Either use capabilities request or
      • Extend the SRS parameter in URL, so multiple projection can be passed
  • On projection change check whether the layers support the new one and ask user accordingly.
  • On creating a new layer ask to change projection when necessary.

Replace the current code in WMS with a more generic approach which also works with new layer types when projection data is filled in.

Attachments (0)

Change History (6)

comment:1 Changed 8 years ago by stoecker

Ticket #5142 has been marked as a duplicate of this ticket.

comment:2 Changed 8 years ago by stoecker

Resolution: fixed
Status: newclosed

In [4183/josm]:

fix #6432 - projection handling for TMS and WMS

comment:3 Changed 8 years ago by stoecker

Ticket #5621 has been marked as a duplicate of this ticket.

comment:4 Changed 8 years ago by stoecker

Ticket #6328 has been marked as a duplicate of this ticket.

comment:5 Changed 8 years ago by stoecker

Ticket #6017 has been marked as a duplicate of this ticket.

comment:6 Changed 8 years ago by stoecker

Ticket #5826 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.