Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6431 closed defect (fixed)

exception when moving Member_Of column header in Properties window of a relation

Reported by: katpatuka Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Properties window relation move column header Cc:

Description

Accidently I moved the Member Of column header in the Properties window with the mouse (I did not resize the column width but really moved the header - see image attachment) - this throws an Unexpected Exception in JOSM 4064. Josm seems to be functional still (upload did work) but whenever clicking on any way the Unexpected Exception showed up.

Attachments (1)

josm4064-bug.png (14.4 KB) - added by katpatuka 10 years ago.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by katpatuka

Attachment: josm4064-bug.png added

comment:1 Changed 10 years ago by rickmastfan67

I can confirm that this still happens in r4115. Just was able to duplicate it. Here's a concrete way of duplicating it:

  1. Download a way that has a relation attached to it. (Download way: 116309725)
  2. Scroll down to the relations section of the way properties.
  3. Left click and drag any of the columns (doesn't matter, I've been able to get an error to pop up doing it with any of them)

The result of dragging any of of the columns is an "Unexpected Exception".

Here's the error report:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-06-05 01:31:53
Last Changed Author: stoecker
Revision: 4115
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-06-04 23:33:08 +0200 (Sat, 04 Jun 2011)
Last Changed Rev: 4115

Identification: JOSM/1.5 (4115 en)
Memory Usage: 264 MB / 3640 MB (187 MB allocated, but free)
Java version: 1.6.0_25, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: OpeningHoursEditor (26002)
Plugin: RoadSigns (25192)
Plugin: alignways (25199)
Plugin: buildings_tools (25905)
Plugin: download_along (25190)
Plugin: imageryadjust (25199)
Plugin: mapdust (25839)
Plugin: measurement (25199)
Plugin: michigan_left (25190)
Plugin: openstreetbugs (25664)
Plugin: restart (25199)
Plugin: reverter (26047)
Plugin: turnlanes (25908)
Plugin: turnrestrictions (26079)
Plugin: undelete (26073)
Plugin: utilsplugin2 (26049)

java.lang.NullPointerException
	at org.openstreetmap.josm.gui.dialogs.properties.PropertiesDialog$14.getTableCellRendererComponent(PropertiesDialog.java:691)
	at javax.swing.JTable.prepareRenderer(Unknown Source)
	at javax.swing.plaf.basic.BasicTableUI.paintCell(Unknown Source)
	at javax.swing.plaf.basic.BasicTableUI.paintDraggedArea(Unknown Source)
	at javax.swing.plaf.basic.BasicTableUI.paintCells(Unknown Source)
	at javax.swing.plaf.basic.BasicTableUI.paint(Unknown Source)
	at javax.swing.plaf.ComponentUI.update(Unknown Source)
	at javax.swing.JComponent.paintComponent(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintToOffscreen(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paint(Unknown Source)
	at javax.swing.RepaintManager.paint(Unknown Source)
	at javax.swing.JComponent._paintImmediately(Unknown Source)
	at javax.swing.JComponent.paintImmediately(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.seqPaintDirtyRegions(Unknown Source)
	at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(Unknown Source)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$000(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.awt.EventQueue$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

comment:2 Changed 10 years ago by rickmastfan67

Version: testedlatest

comment:3 Changed 10 years ago by stoecker

Resolution: fixed
Status: newclosed

In [4119/josm]:

fix #6431 - NPE

comment:4 Changed 10 years ago by stoecker

Ticket #5693 has been marked as a duplicate of this ticket.

comment:5 Changed 10 years ago by stoecker

Ticket #6133 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.