Modify

Opened 9 years ago

Closed 8 years ago

Last modified 5 years ago

#6345 closed defect (fixed)

shortcuts info not adjusted to language (Was: shortcuts info not adjusted to language if start option --language is used.)

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: shortcut language javabug Cc:

Description (last modified by Don-vip)

I justed noticed this, but problem seems exist for quite a while (already in r3966)

I started josm with --language and the language is english but the shortcut info is still german (local)

r4079, openjdk

Attachments (0)

Change History (10)

comment:1 Changed 9 years ago by skyper

Summary: shortcuts info not adjusted to language if start option --language is used.shortcuts info not adjusted to language (Was: shortcuts info not adjusted to language if start option --language is used.)

This also happens if the language set in preferences is not the default local one.

Or do I miss some java libs on my system ?

r4105, openjdk, Debian stable (with little testing).

Last edited 9 years ago by skyper (previous) (diff)

comment:2 Changed 9 years ago by skyper

Ticket #6841 has been marked as a duplicate of this ticket.

comment:3 Changed 9 years ago by dieterdreist

the problem appears also in the console messages (silent shortcut conflicts).

comment:4 in reply to:  3 ; Changed 9 years ago by skyper

Replying to dieterdreist:

the problem appears also in the console messages (silent shortcut conflicts).

Your problems with changing shortcuts has nothing todo with this ticket and belongs to #6840. Please add more information eg the console output there.

Did you try it with a new/empty josm directory ? Have a look at Help/ResetPreferences

comment:5 in reply to:  4 Changed 9 years ago by dieterdreist

Replying to skyper:

Replying to dieterdreist:

the problem appears also in the console messages (silent shortcut conflicts).

Your problems with changing shortcuts has nothing todo with this ticket and belongs to #6840. Please add more information eg the console output there.

yes, I know that these 2 issues are not connected (I created a separate ticket for the language problem). I found the troublemaker which causes #6840 (utils2 plugin) and already added information regarding this to the ticket.

comment:6 Changed 8 years ago by stoecker

Ticket #7898 has been marked as a duplicate of this ticket.

comment:7 Changed 8 years ago by Don-vip

Description: modified (diff)

From KeyEvent.getKeyText() javadoc :

These strings can be localized by changing the awt.properties file. 

I do not have any idea how we are supposed to do that. Instead, I found this on Oracle website:

2.3 Key Events

This section describes issues with key events.
2.3.1 General Unresolved Keyboard Issues

The following keyboard issues are currently unresolved.
    Changing the default locale at runtime does not change the text that is displayed for the menu accelerator keys.

Looks like a Java bug to me. They don't even say they will fix it, but I don't see a workaround right now.

comment:8 Changed 8 years ago by Don-vip

Bug found. There's a dirty hack submitted as a workaround.

EDIT: it works !

Last edited 5 years ago by Don-vip (previous) (diff)

comment:9 Changed 8 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 5358/josm:

fix #6345 - Display shortcut accelerators in tooltips with the language used by JOSM

comment:10 Changed 5 years ago by Don-vip

Keywords: javabug added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.