Modify

Opened 11 years ago

Closed 11 years ago

#6324 closed enhancement (wontfix)

error al importar datos de OSM y datos en bruto al mismo tiempo (casillas marcadas al mismo tiempo)

Reported by: anonymous Owned by: anonymous
Priority: normal Milestone:
Component: Plugin elevationprofile Version: latest
Keywords: Cc:

Description

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-04-26 01:31:34
Last Changed Author: bastiK
Revision: 4064
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-04-25 20:32:26 +0200 (Mon, 25 Apr 2011)
Last Changed Rev: 4064

Identification: JOSM/1.5 (4064 es)
Memory Usage: 243 MB / 494 MB (66 MB allocated, but free)
Java version: 1.6.0_24, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows XP
Dataset consistency test: No problems found

Plugin: AddrInterpolation (25199)
Plugin: ColumbusCSV (25192)
Plugin: Create_grid_of_ways (25192)
Plugin: DirectDownload (25199)
Plugin: DirectUpload (25199)
Plugin: ElevationProfile (25192)
Plugin: ImageWayPoint (25192)
Plugin: ImportImagePlugin (25192)
Plugin: OpeningHoursEditor (25190)
Plugin: PicLayer (25219)
Plugin: RoadSigns (25192)
Plugin: SeaMapEditor (25549)
Plugin: SimplifyArea (25881)
Plugin: alignways (25199)
Plugin: buildings_tools (25905)
Plugin: contourmerge (25626)
Plugin: dataimport (25192)
Plugin: download_along (25190)
Plugin: editgpx (25407)
Plugin: epsg31287 (25262)
Plugin: ext_tools (25338)
Plugin: globalsat (25192)
Plugin: gpxfilter (25456)
Plugin: graphview (25199)
Plugin: imageryadjust (25199)
Plugin: importvec (25469)
Plugin: lakewalker (25192)
Plugin: livegps (25833)
Plugin: measurement (25199)
Plugin: multipoly-convert (25192)
Plugin: namemanager (1.1)
Plugin: openstreetbugs (25664)
Plugin: openvisible (25192)
Plugin: osmarender (25371)
Plugin: pdfimport (25546)
Plugin: photo_geotagging (25199)
Plugin: proj4j (25454)
Plugin: public_transport (25192)
Plugin: reltoolbox (25751)
Plugin: restart (25199)
Plugin: reverter (25578)
Plugin: routes (25199)
Plugin: routing (25843)
Plugin: turnrestrictions (25845)
Plugin: undelete (25199)
Plugin: utilsplugin2 (25912)
Plugin: walkingpapers (25191)
Plugin: waydownloader (25190)
Plugin: waypoint_search (25191)
Plugin: wayselector (25191)

java.lang.RuntimeException: WPT must not be null, profile ElevationProfileBase [start=Mon May 09 01:25:04 BOT 2011, end=Mon May 09 01:25:04 BOT 2011, minHeight=0, maxHeight=0]

at org.openstreetmap.josm.plugins.elevation.gui.DefaultElevationProfileRenderer.renderWayPoint(DefaultElevationProfileRenderer.java:139)
at org.openstreetmap.josm.plugins.elevation.gui.ElevationProfileLayer.paint(ElevationProfileLayer.java:206)
at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:450)
at org.openstreetmap.josm.gui.MapView.paint(MapView.java:529)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JSplitPane.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at javax.swing.JLayeredPane.paint(Unknown Source)
at javax.swing.JComponent.paintChildren(Unknown Source)
at javax.swing.JComponent.paintToOffscreen(Unknown Source)
at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(Unknown Source)
at javax.swing.RepaintManager$PaintManager.paint(Unknown Source)
at javax.swing.BufferStrategyPaintManager.paint(Unknown Source)
at javax.swing.RepaintManager.paint(Unknown Source)
at javax.swing.JComponent.paint(Unknown Source)
at java.awt.GraphicsCallback$PaintCallback.run(Unknown Source)
at sun.awt.SunGraphicsCallback.runOneComponent(Unknown Source)
at sun.awt.SunGraphicsCallback.runComponents(Unknown Source)
at java.awt.Container.paint(Unknown Source)
at java.awt.Window.paint(Unknown Source)
at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
at javax.swing.RepaintManager.seqPaintDirtyRegions(Unknown Source)
at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(Unknown Source)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$000(Unknown Source)
at java.awt.EventQueue$1.run(Unknown Source)
at java.awt.EventQueue$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (6)

comment:1 Changed 11 years ago by anonymous

Summary: error al importar datos de SOM y datos en bruto al mismo tiempo (casillas marcadas al mismo tiempo)error al importar datos de OSM y datos en bruto al mismo tiempo (casillas marcadas al mismo tiempo)

comment:2 Changed 11 years ago by stoecker

Component: CorePlugin elevationprofile
Owner: changed from team to OliverW

comment:3 Changed 11 years ago by OliverW

Resolution: wontfix
Status: newclosed

Please describe the error either in english or german.

The cause for this error seems to be that your GPX does not contain any elevation data.

comment:4 Changed 11 years ago by stoecker

Resolution: wontfix
Status: closedreopened

You should nevertheless prevent exceptions and provide a proper error handling for that case.

comment:5 Changed 11 years ago by OliverW

Owner: changed from OliverW to anonymous
Status: reopenedneedinfo

comment:6 Changed 11 years ago by OliverW

Resolution: wontfix
Status: needinfoclosed

Obviously I was not clear enough. So again, I can neither reproduce nor fix this error with the existing information.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain anonymous.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.