Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6267 closed defect (fixed)

ERROR

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2011-03-09 12:21:24
Last Changed Author: Upliner
Revision: 3966
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2011-03-09 11:48:50 +0100 (Wed, 09 Mar 2011)
Last Changed Rev: 3966

Identification: JOSM/1.5 (3966 es)
Memory Usage: 269 MB / 494 MB (33 MB allocated, but free)
Java version: 1.6.0_24, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows 7
Dataset consistency test: No problems found

Plugin: openstreetbugs (25540)
Plugin: turnrestrictions (25465)

java.lang.NullPointerException
	at org.openstreetmap.josm.io.Capabilities.isOnImageryBlacklist(Capabilities.java:140)
	at org.openstreetmap.josm.data.imagery.ImageryInfo.isBlacklisted(ImageryInfo.java:242)
	at org.openstreetmap.josm.actions.AddImageryLayerAction.updateEnabledState(AddImageryLayerAction.java:33)
	at org.openstreetmap.josm.actions.JosmAction$LayerChangeAdapter.layerAdded(JosmAction.java:201)
	at org.openstreetmap.josm.gui.MapView.fireLayerAdded(MapView.java:146)
	at org.openstreetmap.josm.gui.MapView.addLayer(MapView.java:281)
	at org.openstreetmap.josm.Main.addLayer(Main.java:267)
	at org.openstreetmap.josm.actions.AddImageryLayerAction.actionPerformed(AddImageryLayerAction.java:27)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown S

Attachments (0)

Change History (6)

comment:1 Changed 10 years ago by stoecker

Resolution: fixed
Status: newclosed

In [4062/josm]:

fix #6267 - NPE

comment:2 Changed 10 years ago by bastiK

In [4063/josm]:

see #6267, check for null

comment:3 Changed 10 years ago by stoecker

You're sure your right bastiK? imageryBlacklist should never be null, as it is initialized in constructor.

comment:4 Changed 10 years ago by bastiK

The NPE was thrown here: http://josm.openstreetmap.de/browser/josm/trunk/src/org/openstreetmap/josm/io/Capabilities.java?rev=3934#L140

  if (url.matches(blacklistRegex)) {

so url can be null (for whatever reason).

Mjulius fixed this in http://josm.openstreetmap.de/changeset/3986/josm/trunk/src/org/openstreetmap/josm/io/Capabilities.java, so this should have been closed as duplicate in the first place

comment:5 Changed 10 years ago by stoecker

OK, we were both wrong :-) Well, that's the issue when theoretically fixing bugs without actually testing.

comment:6 Changed 10 years ago by simon04

Ticket #6183 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.